Bug 178316 - kdelibs-apidocs: use versioned Obsoletes: kdelibs-docs
kdelibs-apidocs: use versioned Obsoletes: kdelibs-docs
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 08:34 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 09:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample kdelibs.spec used by kde-redhat (24.71 KB, text/plain)
2006-01-19 08:34 EST, Rex Dieter
no flags Details

  None (edit)
Description Rex Dieter 2006-01-19 08:34:34 EST
It was discussed on the mailing lists, but so we can track it.  It would be  
nice to package kdelibs' apidocs separately, ideally as a noarch pkg,  
containing (mostly):  
/usr/share/doc/HTML/en/kdelibs-apidocs  
 
Attached is a sample implementation we use with the kde-redhat pkgs that will 
create a noarch kdelibs-apidocs when built with 
rpmbuild -bb --target=noarch kdelibs.spec
Comment 1 Rex Dieter 2006-01-19 08:34:34 EST
Created attachment 123427 [details]
sample kdelibs.spec used by kde-redhat
Comment 2 Rex Dieter 2006-01-19 08:55:12 EST
Oops, just noticed kdelibs-3.5.0-5 packages these as -docs.  Any chance of 
renaming to -apidocs to be compatible? 
 
(It's not that big of a deal, we can change to match, but it'll just be a 
little more painful) 
Comment 3 Ngo Than 2006-01-19 10:06:42 EST
it's fixed in next kdelibs rebuild
Comment 4 Rex Dieter 2006-01-26 15:16:13 EST
any chance of kdelibs-apidocs being noarch?
Comment 5 Rex Dieter 2006-03-28 14:34:58 EST
Too late now to change to noarch.  native arch builds are now in the wild.

The crappy part is that yum (seems to) always prefer native arch versions of
same-named pkgs, even though there are newer noarch ones available.

Case-in-point: Using 'yum update' upgrade to kde-redhat's
kdelibs-apidocs-3.5.2.noarch pkg fails.
Comment 6 Rex Dieter 2006-03-28 14:36:42 EST
Only alternative I see (I strongly think kdelibs-apidocs *should* be noarch) is
to rename the package (go back to kdelibs-docs?), and have it
Obsoletes: kdelibs-apidocs
Comment 7 Rex Dieter 2006-04-03 07:32:02 EDT
In the meantime, please use a *versioned* Obsoletes, like
Obsoletes: kdelibs-docs < %{epoch}:%{version}-%{release}
Comment 8 Ngo Than 2006-05-18 09:44:28 EDT
The problem is that our build system does not allow to build package arch and
noarch simultaneously with only one srpm!

For doing that, it requires 2 srpm sources which we really don't want and always
avoid.

To comment #5: it seems a bug in yum and needs to be fixed.
Comment 9 Rex Dieter 2006-05-18 09:47:03 EDT
Can you at least use a versioned Obsoletes?
Comment 10 Ngo Than 2006-05-18 09:55:43 EDT
sure, it's now in CVS.

Note You need to log in before you can comment on or make changes to this bug.