Bug 1783232 - gluster-smb:glusto-test access gluster by cifs test write report Device or resource busy
Summary: gluster-smb:glusto-test access gluster by cifs test write report Device or re...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core
Version: rhgs-3.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: RHGS 3.5.z Batch Update 3
Assignee: Anoop C S
QA Contact: Aditya Ramteke
URL:
Whiteboard:
Depends On: 1741734 1781486
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-13 11:49 UTC by Anoop C S
Modified: 2020-12-17 04:51 UTC (History)
11 users (show)

Fixed In Version: glusterfs-6.0-38
Doc Type: No Doc Update
Doc Text:
Clone Of: 1741734
Environment:
Last Closed: 2020-12-17 04:50:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:5603 0 None None None 2020-12-17 04:51:35 UTC

Description Anoop C S 2019-12-13 11:49:56 UTC
+++ This bug was initially created as a clone of Bug #1741734 +++

Description of problem:
Write data Device or resource busy by client access volume when do gluster volume set testvol_distributed-replicated user.cifs on.

Version-Release number of selected component (if applicable):
gluster-6 extras/hook-scripts/start/post/S30samba-start.sh and ./extras/hook-scripts/set/post/S30samba-set.sh script

How reproducible:
enable gluster cifs and access volume by cifs. Smb client will report Device or resource busy when we echo or do cat command file

Steps to Reproduce:
1.create 2*(2+1) test volume
2.gluster v set test user.cifs on
3.On the client and mount test by cifs
4.create file and echo "11111" >> file, will report Device or resource busy.

Actual results:
can not write or read file

Expected results:
can write or read file as usual

Additional info:
smb client:
mount.cifs //10.10.51.22/gluster-testvol_dispersed /mnt/testvol_dispersed
cd /mnt/testvol_dispersed
cat file 
cat: file: Device or resource busy
echo "11111" >> file 
-bash: file: Device or resource busy

--- Additional comment from Worker Ant on 2019-08-16 08:01:58 IST ---

REVIEW: https://review.gluster.org/23240 (gluster-smb:add smb parameter when  access gluster by cifs) posted (#1) for review on master by None

--- Additional comment from Worker Ant on 2019-08-21 19:30:32 IST ---

REVIEW: https://review.gluster.org/23240 (gluster-smb:add smb parameter when  access gluster by cifs) merged (#4) on master by Amar Tumballi

Comment 11 errata-xmlrpc 2020-12-17 04:50:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (glusterfs bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5603


Note You need to log in before you can comment on or make changes to this bug.