Bug 1783254 - the code of rdma-core is compiled in %install instead of %build
Summary: the code of rdma-core is compiled in %install instead of %build
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rdma-core
Version: 8.2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 8.2
Assignee: Honggang LI
QA Contact: Zhang Yi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-13 12:57 UTC by Kamil Dudka
Modified: 2020-04-28 16:57 UTC (History)
5 users (show)

Fixed In Version: rdma-core-26.0-7.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:57:33 UTC
Type: Bug
Target Upstream Version:
kdudka: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1865 None None None 2020-04-28 16:57:51 UTC

Description Kamil Dudka 2019-12-13 12:57:46 UTC
Description of problem:
The `make` command invoked in %build does not compile any code.  The compilation is triggered by the `make install` command in %install, which is too late.


Version-Release number of selected component (if applicable):
rdma-core-26.0-6.el8


Steps to Reproduce:
1. rpmbuild -bc rdma-core.spec
2. rpmbuild -bi rdma-core.spec --short-circuit


Actual results:
Compilation of the source code happens in step 2.


Expected results:
Compilation of the source code happens in step 1.


Additional info:
This bug prevents the package from being properly scanned by Covscan.


Brew build.log:
http://download.eng.bos.redhat.com/brewroot/vol/rhel-8/packages/rdma-core/26.0/6.el8/data/logs/x86_64/build.log

Comment 1 Honggang LI 2019-12-16 10:14:19 UTC
(In reply to Kamil Dudka from comment #0)
> Description of problem:
> The `make` command invoked in %build does not compile any code.  The
> compilation is triggered by the `make install` command in %install, which is
> too late.
> 
> 
> Version-Release number of selected component (if applicable):
> rdma-core-26.0-6.el8
> 
> 
> Steps to Reproduce:
> 1. rpmbuild -bc rdma-core.spec
> 2. rpmbuild -bi rdma-core.spec --short-circuit
> 
> 
> Actual results:
> Compilation of the source code happens in step 2.
> 
> 
> Expected results:
> Compilation of the source code happens in step 1.

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=25392381
http://download.eng.bos.redhat.com/brewroot/work/tasks/2391/25392391/build.log

I had a scratch build. Does this work for you?

Thanks

Comment 2 Kamil Dudka 2019-12-16 10:58:33 UTC
(In reply to Honggang LI from comment #1)
> https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=25392381
> http://download.eng.bos.redhat.com/brewroot/work/tasks/2391/25392391/build.log
> 
> I had a scratch build. Does this work for you?

I confirm that the above build works as expected.  Tested with:

% curl -JO http://download.eng.bos.redhat.com/brewroot/work/tasks/2383/25392383/rdma-core-26.0-7.el8.src.rpm
% covscan mock-build --config=rhel-8-x86_64 rdma-core-26.0-7.el8.src.rpm
Task info: https://cov01.lab.eng.brq.redhat.com/covscanhub/task/155831/

Thanks for the fix!

Comment 8 errata-xmlrpc 2020-04-28 16:57:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1865


Note You need to log in before you can comment on or make changes to this bug.