Bug 1783312 - Only the first occurrence of a console log link variable gets replaced
Summary: Only the first occurrence of a console log link variable gets replaced
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1782873 (view as bug list)
Depends On: 1781827
Blocks: 1782873
TreeView+ depends on / blocked
 
Reported: 2019-12-13 14:53 UTC by Robb Hamilton
Modified: 2020-02-19 05:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1781827
Environment:
Version: 4.3.0-0.nightly-2019-12-09-035405 Cluster ID: bfecd802-f81b-4cbb-b826-7d1b216d9eb0 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0
Last Closed: 2020-02-19 05:39:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3778 0 None closed [release-4.3] Bug 1783312: Replace multiple occurrences of log link variable expressions 2020-02-17 07:29:21 UTC
Red Hat Product Errata RHBA-2020:0492 0 None None None 2020-02-19 05:40:03 UTC

Description Robb Hamilton 2019-12-13 14:53:20 UTC
+++ This bug was initially created as a clone of Bug #1781827 +++

Console log links with multiple occurrences of the same variable expression aren't handled correctly. Only the first expression is replaced. Console should replace all occurrences.

--- Additional comment from Samuel Padgett on 2019-12-10 16:31:19 UTC ---

https://github.com/openshift/console/pull/3745

Comment 1 Samuel Padgett 2019-12-13 14:56:28 UTC
*** Bug 1782873 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-02-19 05:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0492


Note You need to log in before you can comment on or make changes to this bug.