Bug 178346 - Installer crashed I810
Installer crashed I810
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 13:10 EST by Chris Negus
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 00:05:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Negus 2006-01-19 13:10:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The installer crashed while starting X. Probing reported this video card:
Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller]
I rebooted and paused just before the crash. Here's what X.log said:

---------------
(EE) GARTInit: Unable to open /dev/agpgart (no such device)
(EE) I810(0): AGP GART support is not available. Make sure your kernel has
        agpgart support or that the agpgart kernel module is loaded.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
-----------------
The final crash message is:

mini-wm: Fatal IO error 104 (Connection reset by peer) on X server :1.0.

The bug seems similar to 108777 and 52047. However, the graphical install worked on this same machine for FC5-T1, so I thought I should enter this bug in case something new came up.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot FC5-T2 DVD
2. Press Enter (for default graphical install)
3. Installer crashes when X attempts to start
  

Actual Results:  Install crashes

Expected Results:  X should have started for graphical install.

Additional info:

I was able to do a text-based install, although the screen was somewhat scrambled. After that, the GUI worked just fine after firstboot.
Comment 1 Jeremy Katz 2006-01-23 00:05:31 EST
This is because agpgart got removed from the i586 kernel.  davej just added it
back based on reports on fedora-test-list, so should be good in rawhide

Note You need to log in before you can comment on or make changes to this bug.