Bug 1783520 - open port 8443 on firewall for Ceph Dashboard
Summary: open port 8443 on firewall for Ceph Dashboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 4.0
Assignee: Dimitri Savineau
QA Contact: Madhavi Kasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-13 21:04 UTC by John Brier
Modified: 2020-01-31 12:48 UTC (History)
10 users (show)

Fixed In Version: ceph-ansible-4.0.7-1.el8cp, ceph-ansible-4.0.7-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:48:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible log file (8.21 MB, text/plain)
2019-12-13 21:04 UTC, John Brier
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 4862 0 None closed ceph-infra: open dashboard port on monitor 2020-07-08 09:37:28 UTC
Github ceph ceph-ansible pull 4872 0 None closed ceph-infra: open dashboard port on monitor (bp #4862) 2020-07-08 09:37:28 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:48:36 UTC

Description John Brier 2019-12-13 21:04:51 UTC
Created attachment 1644983 [details]
ansible log file

Description of problem:

Dashboard is installed by default now but port 8443 is not opened by ceph-ansible.

In /etc/ansible/hosts I have:

[grafana-server]
jb-ceph4-mon

yet 8443 is not opened on jb-ceph4-mon

[root@jb-ceph4-mon ~]# firewall-cmd --list-all
public (active)
  target: default
  icmp-block-inversion: no
  interfaces: enp1s0
  sources: 192.168.122.0/24
  services: ceph ceph-mon cockpit dhcpv6-client ssh
  ports: 9100/tcp 3000/tcp 9092/tcp 9093/tcp
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 

I can't connect to the dashboard as instructed:

TASK [ceph-dashboard : print dashboard URL] ************************************************************
task path: /usr/share/ceph-ansible/roles/ceph-dashboard/tasks/main.yml:5
Friday 13 December 2019  15:53:03 -0500 (0:00:02.166)       0:03:45.120 ******* 
ok: [jb-ceph4-mon] => 
  msg: The dashboard has been deployed! You can access your dashboard web UI at http://jb-ceph4-mon:8443/ as an 'admin' user with 'p@ssw0rd' password.
META: ran handlers


If I disable the firewall I can load the dashboard without problem.

[root@jb-ceph4-mon ~]# systemctl stop firewalld
[root@jb-ceph4-mon ~]# firewall-cmd --list-all
FirewallD is not running



Version-Release number of selected component (if applicable):


How reproducible:

100%


Steps to Reproduce:
1. Install RHCS 4
2. Try to browse to dashboard http://<hostname>:8443

Actual results:

connection refused.

Expected results:

connection not refused and dashboard loads.


Additional info:

ceph-ansible-4.0.6-1.el8cp.noarch

[root@jb-ceph4-mon ~]# rpm -qa | grep ceph
ceph-mon-14.2.4-84.el8cp.x86_64
python3-ceph-argparse-14.2.4-84.el8cp.x86_64
ceph-mgr-dashboard-14.2.4-84.el8cp.noarch
ceph-base-14.2.4-84.el8cp.x86_64
ceph-common-14.2.4-84.el8cp.x86_64
python3-cephfs-14.2.4-84.el8cp.x86_64
ceph-selinux-14.2.4-84.el8cp.x86_64
ceph-grafana-dashboards-14.2.4-84.el8cp.noarch
libcephfs2-14.2.4-84.el8cp.x86_64
ceph-mgr-14.2.4-84.el8cp.x86_64
ceph-mgr-diskprediction-local-14.2.4-84.el8cp.noarch

In group_vars/all.yml There is this line:

#configure_firewall: True

I tried uncommenting it to be explicit but it didn't help.

Comment 9 errata-xmlrpc 2020-01-31 12:48:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.