Bug 178358 - Kernel panic: IO-APIC + timer doesn't work!
Kernel panic: IO-APIC + timer doesn't work!
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
high Severity high
: ---
: ---
Assigned To: Robert Hentosh
Brian Brock
:
Depends On:
Blocks: 176344 185624 198694 200936 246028
  Show dependency treegraph
 
Reported: 2006-01-19 14:57 EST by Robert Hentosh
Modified: 2010-10-21 23:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 10:41:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to resolve issue. (4.16 KB, patch)
2006-01-19 14:57 EST, Robert Hentosh
no flags Details | Diff

  None (edit)
Description Robert Hentosh 2006-01-19 14:57:49 EST
Description of problem:  When booting some of the newer systems that have 
longer running SMI routines (for USB legacy keyboard emulation). The system 
may panic with the message:

  Kernel panic - not syncing: IO-APIC + timer doesn't work! Try using 'noapic' 
kernel parameter.

This is caused by SMI's occuring and stealing CPU cycles when the kernel is 
attempting to calibrate the Bogomips (i.e. loops_per_jiffy) value.

Version-Release number of selected component (if applicable): RHEL4 
(GOLD,U1,U2,U3 beta)


How reproducible:  Very intermittent. Can be exasperated by typing on USB 
keyboard during boot.


Steps to Reproduce:
1. Reboot a system that uses SMI's (E.g. Dell PE6800)
2. Type on USB keyboard and/or place in reboot loop
3. repeat until failure.
  
Actual results:
System panics on boot.

Expected results:
No panic.

Additional info:
Comment 1 Robert Hentosh 2006-01-19 14:57:49 EST
Created attachment 123453 [details]
Patch to resolve issue.
Comment 4 Samuel Benjamin 2006-02-09 14:45:34 EST
Raising priority to high based on Dell's U4 consideration.
Comment 5 Larry Troan 2006-03-02 10:25:20 EST
Engineering asks if we can we make this bug PUBLIC.
Comment 6 Amit Bhutani 2006-03-02 15:02:47 EST
Do not see anything that should prevent this from being a public bug. Please go 
ahead and make it public.
Comment 11 Bob Johnson 2006-04-11 12:51:20 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 14 Linda Wang 2006-06-23 19:51:48 EDT
Robert, any upstream status on this issue?  
Move to U5 prop list.
Comment 15 RHEL Product and Program Management 2006-08-16 16:50:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this enhancement by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This enhancement is not yet committed for inclusion in an Update
release.
Comment 16 Larry Troan 2006-08-25 15:27:53 EDT
Pinged Robert and asked for upstream status on the proposed patch (comment #14).

Setting status to NEEDINFO waiting Robert's response.
Comment 19 Peter Martuccelli 2006-11-22 09:45:02 EST
The suggested patch is not upstream.
Comment 21 Issue Tracker 2007-04-19 16:47:59 EDT
Unfortunately, this issue was unable to be addressed in RHEL4.5 due to the
patch not being accepted upstream. We've moved it onto the list for
RHEL4.6, but at last check the patch was still not upstream. Can Dell
update us on the upstream status of this patch?

Internal Status set to 'Waiting on Customer'
Status set to: Waiting on Client

This event sent from IssueTracker by gcase 
 issue 86418
Comment 22 Gary Case 2007-05-08 14:02:03 EDT
Unfortunately, this issue was unable to be addressed in RHEL4.5 due to the patch
not being accepted upstream. We've moved it onto the list for RHEL4.6, but at
last check the patch was still not upstream. Can Dell update us on the upstream
status of this patch?
Comment 23 RHEL Product and Program Management 2007-05-09 06:56:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 25 Peter Martuccelli 2007-06-19 10:35:50 EDT
NAK on this request for R4.6 with proposed patch in comment #1.  Submitter
should review the problem and submit a backport of an upstream patch.
Comment 26 RHEL Product and Program Management 2007-06-19 10:41:22 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.