Bug 178362 - KDE "Run command..." window does not receive focus when started over certain windows
KDE "Run command..." window does not receive focus when started over certain ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 15:15 EST by Dorin Lazar
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 13:37:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dorin Lazar 2006-01-19 15:15:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.0 (like Gecko)

Description of problem:
 KDE "Run command..." window does not receive focus when certain applications 
are active (e.g.: Konqueror, Control Center, KDevelop, etc. ). However, if 
kate, or the desktop have the focus the "Run command..." window will take the 
focus correctly. This may be linked to the focus stealing prevention settings. 
 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a Konqueror window  
2. Press ALT-F2 (or go to the menu and select Run...)  
 
    

Actual Results:  The "Run Command..." window is not active, it looks grayed, although it shows 
a blinking cursor. The active window remains 'Konqueror'. 

Expected Results:  The focus should have gone to the "Run Command..." window. 

Additional info:

The same happens for lots of other applications instead of konqueror. Note, 
however, that if 'kate' is the active application, or the desktop, the "Run 
Command..." window takes the focus correctly.
Comment 1 Rahul Sundaram 2006-02-20 05:49:03 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Ngo Than 2006-02-20 13:37:16 EST
i cannot reproduce this problem with current rawhide. it works for me.
You should please update to the current rawhide. Thanks

Note You need to log in before you can comment on or make changes to this bug.