Bug 178370 - byzanz segfaults when run under VNC
byzanz segfaults when run under VNC
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: byzanz (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 15:51 EST by Jeffrey C. Ollie
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 09:41:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey C. Ollie 2006-01-19 15:51:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
byzanz segfaults when run under VNC.

Version-Release number of selected component (if applicable):
byzanz-0.0.3-2

How reproducible:
Always

Steps to Reproduce:
1. Run byzanz
2.
3.
  

Actual Results:  Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1211094112 (LWP 23477)]
0x0804d966 in gifenc_quantize_image (
    data=0xb7301800
"I\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\t"...,
width=1024, height=768, bpp=2, rowstride=2048, alpha=1,
    byte_order=1234, max_colors=255) at quantize.c:383
383           GIFENC_READ_TRIPLET (color, row);
(gdb) where
#0  0x0804d966 in gifenc_quantize_image (
    data=0xb7301800
"I\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\tI\t"...,
width=1024, height=768, bpp=2, rowstride=2048, alpha=1,
    byte_order=1234, max_colors=255) at quantize.c:383
#1  0x0804bb62 in byzanz_recorder_run_encoder (data=0x8253ed0)
    at byzanzrecorder.c:442
#2  0x0070f2a4 in g_thread_create_full () from /usr/lib/libglib-2.0.so.0
#3  0x009bf262 in start_thread () from /lib/libpthread.so.0
#4  0x0062c14e in clone () from /lib/libc.so.6

Expected Results:  byzanz should have recorded the desktop.

Additional info:

See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=177782#c1 for the initial report.
Comment 1 Jacob Kroon 2006-03-21 16:52:28 EST
I'm getting the same backtrace on a FC5 system with byzanz-0.1.0-6.fc5,
but this is not when using a vnc server, I'm running it as a normal X app.
Comment 2 Jacob Kroon 2006-03-21 17:11:58 EST
I think the problem is that if the server isnt running with a depth of 32bits
per pixel, byzanz will crash. I saw an assertion that looked like that could be
the case. So I experienced the crash when running in 16bpp mode, it works if I
switch to 32bpp mode. I'll notify "Company".
Comment 3 Jacob Kroon 2006-03-22 11:51:05 EST
Just to clear things out, if you compile byzanz yourself, you'll see an
assertion being reached if you run in 16bpp mode, and the app will quit
"normally". I suspect that the fedora package was compiled with g_assert():ions
disabled, so they would compile away to nothing, therefore the program crashed
later, because the check wasn't there anymore.

A quick but ugly fix for this seems to be to add 16bpp -> 32bpp conversion in
the gifenc code. Anyway the author is aware of the problem now.
Comment 4 Jeffrey C. Ollie 2006-07-26 09:41:29 EDT
I'm going to close this, as this needs to be fixed upstream...

Note You need to log in before you can comment on or make changes to this bug.