Bug 178375 - PowerBook sound stopped working
PowerBook sound stopped working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
http://www.kernel.org/git/?p=linux/ke...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 16:32 EST by Frank Arnold
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 12:08:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Arnold 2006-01-19 16:32:06 EST
When doing a '/sbin/modprobe snd-powermac' I get the following with dmesg:
snd: can't request rsrc  0 (Sound Control: 0x80000000:80004fff)

Last known working version: 2.6.15-1.1826.2.10_FC5
With this version I have to load the module manually. But that's another problem.

First known not working version: 2.6.15-1.1854_FC5

Hardware:
[frank@notebook ~]$ cat /proc/cpuinfo
processor       : 0
cpu             : 7447A, altivec supported
clock           : 833.333000MHz
revision        : 0.2 (pvr 8003 0102)
bogomips        : 36.73
timebase        : 18432000
machine         : PowerBook5,6
motherboard     : PowerBook5,6 MacRISC3 Power Macintosh
detected as     : 287 (PowerBook G4 15")
pmac flags      : 0000001b
L2 cache        : 512K unified
pmac-generation : NewWorld

[frank@notebook ~]$ /usr/sbin/kudzu -p -c AUDIO
-
class: AUDIO
bus: MACIO
detached: 0
driver: snd-powermac
desc: "Apple Computer Inc.|PowerMac Sound"

Something has been changed recently. See URL.
Comment 1 Ralf Ertzinger 2006-01-20 04:46:24 EST
I see the same on my iBook G3 500. I have to load the driver manually, it loads
without any obvoius error messages, programs see and are able to use ALSA. I can
also use the mixer to my hearts content, however, there is no sound forthcoming
via the internal speakers or the headphone jack.

Comment 2 Frank Arnold 2006-01-20 06:15:08 EST
No further intervention needed. Stelian Pop sent a patch to linuxppc-dev right
now: http://ozlabs.org/pipermail/linuxppc-dev/2006-January/021021.html

I will close this bug as soon as the fix hits Rawhide kernels.
Comment 3 Dave Jones 2006-01-24 00:19:19 EST
should be fixed in tomorrows build
(also at http://people.redhat.com/davej/kernels/Fedora/devel/)
Comment 4 David Woodhouse 2006-01-24 06:13:49 EST
Davej, did you merge Stelian's patch? What I merged today was something else
which fixed the volume control (and reverted some breakage introduced by Adrian
Bunk's meddling). Not the patch referenced above?

OTOH, my powerbook is working with 2.6.15-1.1871_FC5.
Comment 5 Frank Arnold 2006-01-24 11:06:55 EST
(In reply to comment #4)
> OTOH, my powerbook is working with 2.6.15-1.1871_FC5.

Still the same with 1871. Just wait, it's not urgent.
With 1871 plus Stelian's patch I still have to add the module manually.
Comment 6 Dave Jones 2006-01-24 14:19:28 EST
Sorry, I mistook your volume control patch for Stelians.  False alarm ;)
Comment 7 Ralf Ertzinger 2006-01-29 06:26:35 EST
Sound works again in 2.6.15-1.1881_FC5, but the driver still has to be loaded
manually.
Comment 8 Frank Arnold 2006-02-07 12:08:14 EST
Stelian's patch is included since 2.6.16-rc2, so this part is working again.
Loading issues are tracked in bug 178466.

Note You need to log in before you can comment on or make changes to this bug.