Bug 1783816 - audacious package doesn't install on EL8
Summary: audacious package doesn't install on EL8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: audacious
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-16 01:27 UTC by Ian Mortimer
Modified: 2020-10-23 21:39 UTC (History)
6 users (show)

Fixed In Version: audacious-4.0.5-2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-23 21:39:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Ian Mortimer 2019-12-16 01:27:25 UTC
Description of problem:
audacious package requires gnome-icon-theme but that package doesn't exist in EL8

Version-Release number of selected component (if applicable):

3.10.1-3.el8

How reproducible:

Always

Steps to Reproduce:
1.dnf install audacious
2.
3.

Actual results:
Error: 
 Problem: conflicting requests
  - nothing provides gnome-icon-theme needed by audacious-3.10.1-3.el8.x86_64

Expected results:
audacious and dependencies install without errors.


Additional info:
Rebuilding the srpm with "Requires: gnome-icon-theme" removed from the spec file results in a package which builds and installs.   Adding "Requires: libcanberra-gtk2" to the spec file, ensures that depenency is installed to avoid a warning message when audacious starts.


Context diff is:

--- audacious.spec-	2019-10-21 02:33:45.000000000 +1000
+++ audacious.spec	2019-12-16 11:25:28.937729337 +1000
@@ -52,7 +52,7 @@
 # and updates the icon cache.
 Requires: hicolor-icon-theme
 # for icons such as 'go-next', 'go-previous'
-Requires: gnome-icon-theme
+Requires: libcanberra-gtk2
 
 # Skin packages can require this from xmms and all GUI compatible players
 Provides: xmms-gui

Comment 1 Robert Scheck 2020-06-13 01:06:10 UTC
Yes, this issue unfortunately exists because a non-audacious-package-maintainer decided to simply build audacious for EPEL 8 obviously without testing it and without talking to me as the audacious EPEL package maintainer.

Given I'm targeting audacious 4.0.x for EPEL 8 anyway, I will address this soon when bumping to 4.0.x.

Comment 2 Paul Howarth 2020-09-09 09:32:12 UTC
I had a similar issue with gnome-icon-theme when I built gtkwave for EPEL-8. The dependency was only there to provide ownership of the %{_datadir}/icons/gnome/ directory and various other directories under that one, which my package installed files into. So what I did was to get rid of the dependency on gnome-icon-theme and own the directories I was using myself,
e.g. in the %files section:

%dir %{_datadir}/icons/gnome/
%dir %{_datadir}/icons/gnome/16x16/
%dir %{_datadir}/icons/gnome/16x16/mimetypes/
%{_datadir}/icons/gnome/16x16/mimetypes/gnome-mime-application-vnd.gtkwave-*.png
%dir %{_datadir}/icons/gnome/32x32/
%dir %{_datadir}/icons/gnome/32x32/mimetypes/
%{_datadir}/icons/gnome/32x32/mimetypes/gnome-mime-application-vnd.gtkwave-*.png

Comment 3 Marco van Raaij 2020-10-08 08:04:41 UTC
(In reply to Robert Scheck from comment #1)
> Yes, this issue unfortunately exists because a
> non-audacious-package-maintainer decided to simply build audacious for EPEL
> 8 obviously without testing it and without talking to me as the audacious
> EPEL package maintainer.
> 
> Given I'm targeting audacious 4.0.x for EPEL 8 anyway, I will address this
> soon when bumping to 4.0.x.

Hi Robert,

I am also interested in Audacious for EL8, do you have any updates?

Comment 4 Fedora Update System 2020-10-08 22:18:39 UTC
FEDORA-EPEL-2020-a449a3027e has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-a449a3027e

Comment 5 Marco van Raaij 2020-10-09 10:40:03 UTC
Thanks! Tested and works for me!

Comment 6 Fedora Update System 2020-10-23 21:39:54 UTC
FEDORA-EPEL-2020-a449a3027e has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.