Bug 1783835 - Duplicate Managementstate on page "Local Volume operator Overview"
Summary: Duplicate Managementstate on page "Local Volume operator Overview"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.4.0
Assignee: Hemant Kumar
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-16 04:30 UTC by Liang Xia
Modified: 2020-05-13 21:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:55:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
Local Volume operator Overview.png (110.68 KB, image/png)
2019-12-16 04:30 UTC, Liang Xia
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift local-storage-operator pull 75 0 None closed Bug 1783835: Fix managment state displayName 2020-05-12 15:17:48 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:55:22 UTC

Description Liang Xia 2019-12-16 04:30:14 UTC
Created attachment 1645435 [details]
Local Volume operator Overview.png

Description of problem:
Duplicate Managementstate on page "Local Volume operator Overview"


Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2019-12-14-103510

How reproducible:
Always

Steps to Reproduce:
1. Install local-storage operator.
2. Create local volumes.
3. Check the page "Local Volume operator Overview".

Actual results:
There are two Managementstate on the page.

Expected results:
No duplicate content.

Additional info:
Reference to "Local Volume operator Overview.png"

Comment 1 Jakub Hadvig 2019-12-16 14:48:57 UTC
This is not an Management console issue. The local-storage-operator manifest
is contains ManagementState descriptor in both Spec and Status fields.
Since we are rendering descriptors of both types its understandable the field
is redundant.

Check:
https://github.com/openshift/local-storage-operator/blob/master/manifests/4.4/local-storage-operator.v4.4.0.clusterserviceversion.yaml#L236-L262

Comment 2 bpeterse 2019-12-16 18:28:59 UTC
Agree, this is not a typical field to provide in a status.

Comment 3 bpeterse 2019-12-16 18:33:24 UTC
Reassigning to hekumar@redhat.com to check & see if this was intentionally published on the status.

Comment 4 Samuel Padgett 2019-12-16 19:33:33 UTC
The local storage operator should give different display names to the OLM descriptors if showing both values.

Comment 6 Liang Xia 2019-12-18 13:08:59 UTC
Verified with local-storage-operator.4.4.0-201912170523 on 4.4.0-0.nightly-2019-12-16-124946, now we see "Requested management state"/"Operator management state".

Comment 8 errata-xmlrpc 2020-05-13 21:55:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.