Bug 1783857 - Mix use of "local storage operator" and "local volume operator" can confuse customer
Summary: Mix use of "local storage operator" and "local volume operator" can confuse c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Jan Safranek
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-16 05:35 UTC by Liang Xia
Modified: 2020-05-13 21:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:55:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift local-storage-operator pull 76 0 None None None 2019-12-18 12:14:00 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:55:24 UTC

Description Liang Xia 2019-12-16 05:35:21 UTC
Description of problem:
Both "local storage operator" and "local volume operator" are used, which can confuse customer.
We should consistently use "local storage operator".


Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2019-12-14-103510

How reproducible:
Always

Steps to Reproduce:
1. Install local storage operator.
2. Check several pages for the installed local storage operator.


Actual results:
Some times "local storage operator" is used,
while some times "local volume operator" is used.

Expected results:
Consistently use "local storage operator".

Comment 1 Jan Safranek 2019-12-18 12:31:42 UTC
There is confusion about Local Storage Operator (the operator itself) and Local Volume operator APIs (the CRD / CRs managed by the operator).

I propose using Local Volumes (without "operator") for the CRD / CRs. I.e. Local Storage Operator provides Local Volume API and don't use "operator" anywhere in the API.

Comment 3 Liang Xia 2020-01-07 06:26:42 UTC
Verified the issue is fixed with,

Local Storage 4.4.0-202001062016
OpenShift Version 4.4.0-0.nightly-2020-01-06-072200

Comment 5 errata-xmlrpc 2020-05-13 21:55:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.