Bug 1783858 - Heal Info is hung when I/O is in progress on a gluster block volume
Summary: Heal Info is hung when I/O is in progress on a gluster block volume
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1774011
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-16 05:37 UTC by Ravishankar N
Modified: 2019-12-18 05:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1774011
Environment:
Last Closed: 2019-12-18 05:31:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 23883 None Merged afr: make heal info lockless 2019-12-18 05:30:59 UTC

Description Ravishankar N 2019-12-16 05:37:31 UTC
+++ This bug was initially created as a clone of Bug #1774011 +++

This bug was initially created as a copy of Bug #1721355

I am copying this bug because: 
I'd like to send a patch against it.


Description of problem:
I was observing this issue while working on BZ 1707259. 
When there is no self-heals pending, but there are a lot of I/Os happening on a replicate volume with gluster block profile enabled, heal-info was hung. The moment I/O stopped, the command completed successfully. I'm guessing it has something to do with eager locking but I need to RCA it.

Version-Release number of selected component (if applicable):
rhgs-3.5.0

How reproducible:
Always on my dev VMs.

Steps to Reproduce:
- Create a 1x3 replica volume (3 node setup)
- Apply  gluster-block profile on the volume. (gluster v set $volname group gluster-block)
- Mount a fuse client on another node and run parallel 'dd's :
for i in seq{1..20}; do dd if=/dev/urandom of=FILE_$i bs=1024 count=102400& done
- After 10-20 seconds while the I/O is going on, run heal-info command - It will be hung.


Actual results:
heal info command is hung

Expected results:
It should not be hung.

Comment 1 Worker Ant 2019-12-16 05:38:59 UTC
REVIEW: https://review.gluster.org/23883 (afr: make heal info lockless) posted (#1) for review on release-7 by Ravishankar N

Comment 2 Worker Ant 2019-12-18 05:31:00 UTC
REVIEW: https://review.gluster.org/23883 (afr: make heal info lockless) merged (#1) on release-7 by Ravishankar N


Note You need to log in before you can comment on or make changes to this bug.