Bug 178392 - disklessrc would not load e100 is e1000 is already loaded
Summary: disklessrc would not load e100 is e1000 is already loaded
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-netboot   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Fabio Olive Leite
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-20 01:03 UTC by Konstantin Olchanski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 14:45:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Konstantin Olchanski 2006-01-20 01:03:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.7.10-1.3.2

Description of problem:
In disklessrc::loadmodules() the line "grep "^$MODULE" /proc/modules" prevents the e100 network driver from being loaded if the e1000 driver is already loaded ("grep ^e100 /proc/modules" erroneously matches the e1000 entry).

This results in an unbootable machine because without the e100 driver it does not see the network and booting stops. Connecting the network cable to the GigE interface (the e1000 driver) does not work because the PXE BIOS cannot boot from that interface.

A possible fix is to modify the "grep" line like this:
        if ! `grep "^$MODULE " /proc/modules > /dev/null`; then

Notice the extra space after $MODULE.

K.O.


Version-Release number of selected component (if applicable):
system-config-netboot-0.1.36-1.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. blah...
2.
3.
  

Additional info:

Comment 1 Jason Vas Dias 2006-01-20 17:15:11 UTC
Thanks for pointing out the "^$MODULE" ->  "^$MODULE " change - will apply
today with s-c-nb-0.1.38-1 .

BTW, I've no problems with PXE booting with my e1000 on an IBM Thinkpad T41 .

Comment 2 Jason Vas Dias 2006-02-10 18:34:04 UTC
Fixed with system-config-netboot-0.1.37, now in rawhide


Note You need to log in before you can comment on or make changes to this bug.