Bug 178408 - system-cdinstall-helper is broken
system-cdinstall-helper is broken
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-20 04:11 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 21:36:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-01-20 04:11:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
Running autorun from an FC5T2 DVD in FC4, fails.

$ LANG=C ./autorun
hal devs is {'/dev/hdd': '/media/cdrom'}
Unable to get lock on device /dev/hdd: cd devs locked by system-config-packages
hal devs is {}
Traceback (most recent call last):
  File "/usr/share/system-config-packages/InstallDruid.py", line 522, in ?
    druid.run ()
  File "/usr/share/system-config-packages/InstallDruid.py", line 457, in run
    self.do_system_info_state ()
  File "/usr/share/system-config-packages/InstallDruid.py", line 327, in do_system_info_state
    hdlist = self.method.readHeaders()
  File "/usr/share/system-config-packages/method.py", line 550, in readHeaders
    return GroupSet.HeaderListFromFile(self.baseDir + "/hdlist", self, update_method)
  File "/usr/share/system-config-packages/GroupSet.py", line 527, in __init__
    hdlist = rpm.readHeaderListFromFile(path)
_rpm.error: (2, 'No such file or directory')

Same without LANG=C

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Jeremy Katz 2006-01-20 11:09:23 EST
system-config-packages isn't even in test2, so not sure how you got it installed
(... and, yes, that hasn't made it into pirut yet as the CD stuff isn't pushed
down to the yum level)
Comment 2 Need Real Name 2006-01-20 12:25:40 EST
Hello,
I don't have system-config-packages installed.

I only logged it under that because there is no system-cdinstall-helper package
in bugzilla, so I ran an rpm -q --provides on an FC4 box.

system-cdinstall-helper is the broken bit..
Comment 3 Rahul Sundaram 2006-02-20 06:06:51 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 John Thacker 2006-04-21 21:36:50 EDT
I don't even see autorun on a FC5 DVD.  It must have been there to run
system-config-packages, which was removed.  Hence that's the problem.  Must be
fixed in FC5.

Note You need to log in before you can comment on or make changes to this bug.