Bug 178419 - /sbin/multipath fails when /usr filesystem is a separate partition
/sbin/multipath fails when /usr filesystem is a separate partition
Status: CLOSED DUPLICATE of bug 168321
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2006-01-20 07:06 EST by Gunther Schlegel
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-20 13:05:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gunther Schlegel 2006-01-20 07:06:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
When the device-mapper-multipath package is installed, /etc/rc.d/rc.sysinit tries to start /sbin/multipath. /sbin/multipath fails, because it needs to load libsysfs.so.1, which is located in the /usr filesystem. The /usr filesystem is not mounted at this time, only the root filesystem is.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RHEL4 U2 with a separate /usr filesystem
2. Install device-mapper-multipath
3. Reboot and watch output

Actual Results:  /sbin/multipath fails and complains about missing libsysfs.so.1

Expected Results:  /sbin/multipath should work with error message and actually do it's job.

Additional info:

You need to run /sbin/multipath.static instead of /sbin/multipath, just like you do with the lvm commands. /sbin/multipath.static is already there, you just need to fix the /etc/rc.d/rc.sysinit.
Comment 1 Bill Nottingham 2006-01-20 13:05:36 EST

*** This bug has been marked as a duplicate of 168321 ***

Note You need to log in before you can comment on or make changes to this bug.