Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
When creating IPv6 network, there will be an error which is 'Address not within subnet' if I set the configuration below.
IP Configuration: IPv6 only
IPv6 Network: FEC0::1
Prefix Length: 48
Set DHCP Range
Start: FEC0::1
End: FEC0::10
Version-Release number of selected component (if applicable):
cockpit-machines-208-1.el8.noarch
libvirt-dbus-1.2.0-3.module+el8.1.0+4066+0f1aadab.x86_64
How reproducible:
100%
Steps to Reproduce:
1. Open the network creation dialog
2. Set the network with the configuration below:
name: random string
IP Configuration: IPv6 only
IPv6 Network: FEC0::1
Prefix Length: 48
Set DHCP Range
Start: FEC0::1
End: FEC0::10
Then, click the 'Create' Button
Actual results:
1. There will be an error shown beside the 'End' field. The error is 'Address not within subnet'.
Expected results:
1. The creation of IPv6 network can be created correctly.
Additional info:
The issue here is that the address provided is compressed and we currently do not support that.
If you change that to the expanded equivalent the Network Creation will succeed.
Expanded Address: fec0:0:0:0:0:0:0:1
Compressed Address: fec0::1
I will keep this open as an RFE though.
Verified with package:
cockpit-machines-211-1.el8.noarch
libvirt-dbus-1.2.0-3.module+el8.1.0+4066+0f1aadab.x86_64
Steps:
1. Open the network creation dialog
2. Set the network with the configuration below:
name: random string
Forward Mode:NAT
Device:Automatic
IP Configuration: IPv6 only
IPv6 Network: FEC0::1
Prefix Length: 64
Set DHCP Range
Start: FEC0::1
End: FEC0::10
Then, click the 'Create' Button
3. Click Activate
The network can be create and activate successfully.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2020:1639
Description of problem: When creating IPv6 network, there will be an error which is 'Address not within subnet' if I set the configuration below. IP Configuration: IPv6 only IPv6 Network: FEC0::1 Prefix Length: 48 Set DHCP Range Start: FEC0::1 End: FEC0::10 Version-Release number of selected component (if applicable): cockpit-machines-208-1.el8.noarch libvirt-dbus-1.2.0-3.module+el8.1.0+4066+0f1aadab.x86_64 How reproducible: 100% Steps to Reproduce: 1. Open the network creation dialog 2. Set the network with the configuration below: name: random string IP Configuration: IPv6 only IPv6 Network: FEC0::1 Prefix Length: 48 Set DHCP Range Start: FEC0::1 End: FEC0::10 Then, click the 'Create' Button Actual results: 1. There will be an error shown beside the 'End' field. The error is 'Address not within subnet'. Expected results: 1. The creation of IPv6 network can be created correctly. Additional info: