Bug 178434 - ahci: Probing for hardware fails
Summary: ahci: Probing for hardware fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FCMETA_SATA
TreeView+ depends on / blocked
 
Reported: 2006-01-20 15:48 UTC by Ronny Fischer
Modified: 2013-07-03 02:26 UTC (History)
5 users (show)

Fixed In Version: FC5 Test 3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 18:12:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ronny Fischer 2006-01-20 15:48:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When I try to install FC5 Test2 on an Pentium M Notebook, the installer loads only the ahci driver. After that nothing more happens. When I use "linux noprobe", I can choose the drivers of the installed devices manually and I can go with installing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot FC5 Test2 from DVD.
2.choose standard installation method
3.
  

Actual Results:  After loading the ahci driver for the chipset, the installer doesn't continue loading other modules (e.g. ata_piix). No more options to go on are available, the system is totally halted but accepts a soft-reset.

Expected Results:  The installation should go on showing the results of hardware probing and the first graphical welcome screen.

Additional info:

Tested and applied on IBM Thinkpad R52, Intel 915 integrated graphics controller, ICH6 chipset, 1GB RAM

Comment 1 Chris Adams 2006-02-03 00:36:48 UTC
I'm trying rawhide (2006-02-02) and getting the same results on a Thinkpad Z60m.
 I see:

libata version 1.20 loaded.
ahci 0000:00:1f.2: version 1.2
ahci: probe of 0000:00:1f.2 failed with error -12

Under FC4, ata_piix is used automatically.  When the rawhide installer stops
(still in text mode) because it couldn't find any disks on which to install, I
can manually load ata_piix and it works.

Comment 2 Chris Adams 2006-02-04 17:05:04 UTC
Rawhide on 2006-02-04 properly loaded the ata_piix driver, so I think this is fixed.

Comment 3 Rahul Sundaram 2006-02-20 10:58:53 UTC

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Comment 4 Ronny Fischer 2006-02-23 18:12:00 UTC
Resolved with Fedora Core 5 Test 3.


Note You need to log in before you can comment on or make changes to this bug.