Bug 1784492 - The sctp feature is not available in the LatencySensitive featureset
Summary: The sctp feature is not available in the LatencySensitive featureset
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Casey Callendrello
QA Contact: Weibin Liang
URL:
Whiteboard:
Depends On:
Blocks: 1771572 1785419
TreeView+ depends on / blocked
 
Reported: 2019-12-17 15:17 UTC by Federico Paolinelli
Modified: 2020-05-04 11:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1785419 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:20:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift api pull 550 0 None closed Allow sctp protocol with LatencySensitive FG 2020-11-23 06:43:14 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:20:58 UTC

Description Federico Paolinelli 2019-12-17 15:17:57 UTC
Description of problem:

When switching to the LatencySensitive featureset, we can't expose sctp ports nor services.

Version-Release number of selected component (if applicable):

oc version
Client Version: v4.2.0
Server Version: 4.3.0-0.nightly-2019-12-13-180405

How reproducible:

Always

Steps to Reproduce:
1. Switch to use the LatencySensitive featureset (i.e. applying https://github.com/openshift-kni/baremetal-deploy/blob/master/features/performance/manifests/templates/12-feature-gate-latency-sensitive.yaml.in )

2. Wait for the nodes to be ready again
3. Try to install a service with type SCTP (like https://github.com/fedepaol/sctp_setup/blob/master/server_service.yaml ). 

Actual results:

The Service "sctpserver" is invalid: spec.ports[0].protocol: Unsupported value: "SCTP": supported values: "TCP", "UDP"

Expected results:
The service gets installed properly.

Additional info:
Sctp is enabled in the default featureset:
https://github.com/openshift/api/blob/master/config/v1/types_feature.go#L101

but it's not in the LatencySensitive featureset: https://github.com/openshift/api/blob/master/config/v1/types_feature.go#L127

Comment 2 Federico Paolinelli 2019-12-17 15:31:17 UTC
There is also an open PR about that https://github.com/openshift/api/pull/550

Comment 3 Stephen Cuppett 2019-12-17 19:41:41 UTC
Will need a 4.3.z clone when fix is accepted for backport.

Comment 6 Federico Paolinelli 2019-12-18 18:43:13 UTC
Additional notes:

This should related only to the apiserver, confirmed by the fact that SCTP works properly when using the default featureset.

Below the two PRs that were merged in order to get it work with the default featureset:
https://github.com/openshift/api/pull/504
https://github.com/openshift/cluster-kube-apiserver-operator/pull/658

Comment 9 Xingxing Xia 2019-12-20 02:25:19 UTC
Different feature gates involve different teams. Though they all are defined in above repos, per https://github.com/openshift/api/pull/554/files#diff-a5a3801c705742637eeef3b8e7d76bb8R134 it is sig-network, therefore moving component accordingly.

Comment 11 Federico Paolinelli 2019-12-20 15:03:12 UTC
https://github.com/openshift/cluster-kube-apiserver-operator/pull/702 got merged, so 4.4 is ready to be tested as soon as the nightly is built.

Comment 12 Weibin Liang 2020-01-06 18:57:50 UTC
Tested and verified in 4.4.0-0.nightly-2020-01-06-072200

[root@dhcp-41-193 .git]# oc get svc
NAME         TYPE       CLUSTER-IP       EXTERNAL-IP   PORT(S)            AGE
sctpserver   NodePort   172.30.140.177   <none>        30100:30100/SCTP   2s
[root@dhcp-41-193 .git]# oc get svc -o yaml
apiVersion: v1
items:
- apiVersion: v1
  kind: Service
  metadata:
    creationTimestamp: "2020-01-06T18:53:47Z"
    labels:
      app: sctpserver
    name: sctpserver
    namespace: sctp-demo
    resourceVersion: "50515"
    selfLink: /api/v1/namespaces/sctp-demo/services/sctpserver
    uid: 38a88d10-bc34-43f0-8502-fb8ce4beebe2
  spec:
    clusterIP: 172.30.140.177
    externalTrafficPolicy: Cluster
    ports:
    - name: sctpserver
      nodePort: 30100
      port: 30100
      protocol: SCTP
      targetPort: sctpserver
    selector:
      app: sctpserver
    sessionAffinity: None
    type: NodePort
  status:
    loadBalancer: {}
kind: List
metadata:
  resourceVersion: ""
  selfLink: ""
[root@dhcp-41-193 .git]#

Comment 14 errata-xmlrpc 2020-05-04 11:20:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.