Bug 1784564 - Multiple "Plugin Exception"s reported in Fedora-Rawhide-20191216.n.0
Summary: Multiple "Plugin Exception"s reported in Fedora-Rawhide-20191216.n.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-17 17:29 UTC by Adam Williamson
Modified: 2020-01-07 17:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-02 15:23:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2019-12-17 17:29:37 UTC
In Fedora-Rawhide-20191216.n.0 testing, the journal logs "Plugin Exception"s for many many SELinux configuration plugins:

[adamw@adam tmp]$ journalctl --file var/log/journal/0b4c0705f973441eba2346e3c42b1425/system.journal | grep -i "plugin exception"
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception catchall_labels
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception file
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception openvpn
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception allow_anon_write
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception allow_execstack
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception allow_ftpd_use_nfs
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception cvs_data
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception device
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception httpd_can_sendmail
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception mounton
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception qemu_file_image
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception sshd_root
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception xen_image
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception samba_share
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception sandbox_connect
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception bind_ports
Dec 16 05:40:56 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[834]: Plugin Exception filesystem_associate
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception catchall_labels
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception file
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception openvpn
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception allow_anon_write
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception allow_execstack
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception allow_ftpd_use_nfs
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception cvs_data
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception device
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception httpd_can_sendmail
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception mounton
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception qemu_file_image
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception sshd_root
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception xen_image
Dec 16 05:56:14 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception samba_share
Dec 16 05:56:15 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception sandbox_connect
Dec 16 05:56:15 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception bind_ports
Dec 16 05:56:15 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[765]: Plugin Exception filesystem_associate
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception catchall_labels
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception file
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception openvpn
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception allow_anon_write
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception allow_execstack
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception allow_ftpd_use_nfs
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception cvs_data
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception device
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception httpd_can_sendmail
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception mounton
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception qemu_file_image
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception sshd_root
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception xen_image
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception samba_share
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception sandbox_connect
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception bind_ports
Dec 16 06:12:35 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com setroubleshoot[796]: Plugin Exception filesystem_associate

I'm not sure what the significance of these is, but it looks like a problem. It actually breaks the Cockpit openQA test, funnily, because it expects to find a smartd message on the first page of log output but that doesn't happen any more because these messages crowd it out...

Comment 1 Lukas Vrabec 2019-12-17 20:24:25 UTC
Petr/Vito, 

What's going on here? 

Thanks,
Lukas.

Comment 2 Petr Lautrbach 2020-01-02 09:37:01 UTC
The problem was introduced in commit c55edb36ca68 ("framework: Fix AVC.__typeMatch to handle aliases properly") which was forwardported from stable branch. Unfortunately, stable branch is supposed to be used with sepolicy version which generates a list, while current Fedora version generates a generator.

https://pagure.io/setroubleshoot/pull-request/30

Comment 3 Petr Lautrbach 2020-01-02 15:23:27 UTC
Should be fixed in https://koji.fedoraproject.org/koji/taskinfo?taskID=40052256

Comment 4 Adam Williamson 2020-01-03 21:22:18 UTC
This missed the 20200103.n.0 compose so can't confirm yet if it's fixed. Should make tomorrow's.

Comment 5 Adam Williamson 2020-01-07 17:35:46 UTC
Fix confirmed in later composes, thanks.


Note You need to log in before you can comment on or make changes to this bug.