Bug 178473 - automatic partitioning fails
automatic partitioning fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-20 15:59 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 15:52:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-01-20 15:59:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Epiphany/1.9.4

Description of problem:
In rescue mode, I moved /home to /home.KEEP, deleted the rest, then rebooted to the installer.

The automatic partitioner fells over when I tried to use my existing disk. It said that automatic partitioning was not possible, it may be because I was low on disk space (not true).

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
x

Additional info:

Manual partitioning worked.
Comment 1 Chris Lumens 2006-01-23 15:24:19 EST
Please attach the output of /etc/fstab and /proc/partitions from the installed
system.  Was /home on a separate partition?  Is this an upgrade or a fresh
installation that you were just trying to save your /home on?  Which options did
you choose on the Disk Partitioning Setup screen?
Comment 2 Need Real Name 2006-01-23 15:37:02 EST
/etc/fstab:
LABEL=/1                /                       ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-hdc4         swap                    swap    defaults        0 0

/proc/partitions:
major minor  #blocks  name

  22     0  100000000 hdc
  22     1  100000000 hdc1
  22     2  100000000 hdc2 <-- install partition
  22     3  100000000 hdc3
  22     4  100000000 hdc4
(obscured)

One big partition. On it was /home.KEEP, and nothing else.
Fresh install.

I chose the option to install into existing free space.
Comment 3 Chris Lumens 2006-01-23 15:52:42 EST
Oh, I see what's going on here.  There seems to be some confusion over the
wording of the "install into existing free space" option.  What this means is to
not delete any existing partitions and instead use unpartitioned free space on
the disk to install into.  If you don't have any unpartitioned space, anaconda
is seeing that there's nowhere to install and therefore failing.

For this sort of installation, you really just want to use the manual
partitioning.  You may also want to put /home on its own partition in the future
to make upgrades easier.
Comment 4 Need Real Name 2006-01-23 16:21:40 EST
(In reply to comment #3)
> Oh, I see what's going on here.  There seems to be some confusion over the
> wording of the "install into existing free space" option.

I think it would be good to rename the option "install into unpartitioned space".

Thanks!

Note You need to log in before you can comment on or make changes to this bug.