This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 178479 - DSMLGW code uses non-standard sun.misc.Base64Encoder
DSMLGW code uses non-standard sun.misc.Base64Encoder
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: DSMLGW (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
1.0.2
:
Depends On:
Blocks: 152373 183369 240316
  Show dependency treegraph
 
Reported: 2006-01-20 16:36 EST by Rich Megginson
Modified: 2015-12-07 11:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:59:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Replace sun.misc.BASE64Decoder references. (2.76 KB, patch)
2006-01-23 14:15 EST, Thomas Fitzsimmons
no flags Details | Diff
list of files for fix (310 bytes, text/plain)
2006-02-10 09:47 EST, Rich Megginson
no flags Details
diffs for fix (12.62 KB, text/plain)
2006-02-10 09:48 EST, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2006-01-20 16:36:38 EST
Since this code uses axis and other Apache Jakarta code, we should just use the
jakarta commons codec Base64 classes instead.
Comment 1 Thomas Fitzsimmons 2006-01-23 14:15:28 EST
Created attachment 123586 [details]
Replace sun.misc.BASE64Decoder references.

Here is a patch to replace occurrences of sun.misc.BASE64Decoder with
org.apache.commons.codec.binary.Base64.

In my ds build I copied:

/usr/share/java/jakarta-commons-codec.jar (from
jakarta-commons-codec-1.3-2jpp_2fc in Rawhide)

to

ds/dsmlgwjars/download/codec.jar
Comment 2 Rich Megginson 2006-02-10 09:47:30 EST
Created attachment 124494 [details]
list of files for fix
Comment 3 Rich Megginson 2006-02-10 09:48:04 EST
Created attachment 124495 [details]
diffs for fix
Comment 4 Rich Megginson 2006-02-10 18:17:30 EST
Reviewed by: The team (Thanks!)
Files: https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=124494
Branch: HEAD
Fix Description: Added jakarta-commons-codec.jar to the DS build and 
packaging.  We will need to add this file to the bundle of dsmlgw jar 
files on /share/builds/components.
Platforms tested: Fedora Core 4
Flag Day: no
Doc impact: no
QA impact: should be covered by regular nightly and manual testing
New Tests integrated into TET: none

On Fedora Core 4, DS builds with gcj now!
Comment 5 Nathan Kinder 2007-12-20 14:38:40 EST
Verified that we are using no "sun.*" classes in the DSML gateway code.

Marking as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.