Bug 17848 - sendmail keeps dying
Summary: sendmail keeps dying
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-26 06:34 UTC by Adrian Reber
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-13 06:56:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adrian Reber 2000-09-26 06:34:48 UTC
sendmail in redhat 7.0 dies every half hour or so after it is has been 
started. no hint in any log files why it dies so often.
i downgraded to sendmail included in redhat 6.2 and now the old version is 
stable again

Comment 1 Michael Schwendt 2000-10-08 04:10:26 UTC
I have experienced similar spontaneous dies of sendmail, but haven't seen an
error message yet.

Comment 2 golliher 2000-10-10 17:55:44 UTC
I too have seen similar problems with no error messages to indicate the cause.

Comment 3 Christopher Johnson 2000-10-10 20:44:03 UTC
Are any of you who are experiencing sendmail instability running glibc-2.1.94-3?
It's a fresh update on updates.redhat.com which solves some backward binary
compatibility and DNS resolver issues.  Don't have sendmail daemon running on my
test 7.0 system but the glibc update sounds like it might be relevant.

Comment 4 Adrian Reber 2000-10-11 01:56:24 UTC
Now that i have switched to the new glibc packages sendmail seems stable so far.
5 hours without a crash.

Comment 5 Michael Schwendt 2000-10-13 06:56:11 UTC
I have that glibc installed of course since it has been available at nearby
mirrors. Whether it fixes the sendmail problem, time will tell, don't you think?
;-) If I knew what circumstances caused those sendmail problems, I'd try to
reproduce it with the new glibc. I think it might have been related to timeouts,
i.e. when sendmail hasn't been used for some time and the machine has been
offline.

I haven't encountered any of those mysterious lock-ups recently. The reason
might be the updated glibc...



Note You need to log in before you can comment on or make changes to this bug.