Bug 1784837 - e2e failure: unable to recognize no matches for kind "ClusterServiceBroker" in version "servicecatalog.k8s.io/v1beta1"
Summary: e2e failure: unable to recognize no matches for kind "ClusterServiceBroker" i...
Keywords:
Status: CLOSED DUPLICATE of bug 1784334
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Jesus M. Rodriguez
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-18 12:36 UTC by W. Trevor King
Modified: 2019-12-18 14:03 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-18 14:03:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24306 None closed Bug 1784837: Poll for Service Catalog basic usage test 2020-09-03 23:38:05 UTC
Github openshift origin pull 24315 None closed Bug 1784334: Revert "check ServiceCatalog basic usages in OCP 4.x" 2020-09-03 23:38:05 UTC

Description W. Trevor King 2019-12-18 12:36:47 UTC
CI's seeing lots of failures like [1]:

fail [github.com/openshift/origin/test/extended/operators/service_catalog.go:127]: Unexpected error:
    <*util.ExitError | 0xc00561ede0>: {
        Cmd: "oc --namespace=e2e-test-service-catalog-r57k5 --config=/tmp/admin.kubeconfig create -f /tmp/e2e-test-service-catalog-r57k5-config.json",
        StdErr: "unable to recognize no matches for kind \"ClusterServiceBroker\" in version \"servicecatalog.k8s.io/v1beta1\"",
...
failed: (2m40s) 2019-12-18T05:03:10 "[Feature:Platform] Service Catalog should check basic usages: OCP-24062, OCP-24049, OCP-15600 [Suite:openshift/conformance/parallel]"

Also lots of ContainerStatusUnknown 137s in the logs, but that's bug 1734524 (might be related, might not, I dunno).

Seems to have broken between [2] and [3].  In flight around this test are [4,5], but I thought I'd file a bug to document the impact and track the fix, whether that's "actually fix" or "drop the test".

The ClusterServiceBroker message shows up in 68 failed e2e jobs over the past 24h (5% of all e2e failures).

[1]: https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-origin-installer-e2e-gcp-4.4/365
[2]: https://openshift-release.svc.ci.openshift.org/releasestream/4.4.0-0.ci/release/4.4.0-0.ci-2019-12-17-190052
[3]: https://openshift-release.svc.ci.openshift.org/releasestream/4.4.0-0.ci/release/4.4.0-0.ci-2019-12-18-041739
[4]: https://github.com/openshift/origin/pull/24306
[5]: https://github.com/openshift/origin/pull/24315
[6]: https://search.svc.ci.openshift.org/chart?search=unable%20to%20recognize%20no%20matches%20for%20kind.*ClusterServiceBroker.*in%20version.*servicecatalog.k8s.io

Comment 1 W. Trevor King 2019-12-18 14:03:45 UTC
And apparently this is also a dup of bug 1784334, and a side-effect of some catalog things getting turned on in CI before they were ready.  Big reversion in flight [1].

[1]: https://github.com/openshift/origin/pull/24315

*** This bug has been marked as a duplicate of bug 1784334 ***


Note You need to log in before you can comment on or make changes to this bug.