Bug 1784881 - [e2e-cmd] oc get is ruby-25-centos7 time out
Summary: [e2e-cmd] oc get is ruby-25-centos7 time out
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.2.z
Assignee: Ben Parees
QA Contact: wewang
URL:
Whiteboard:
Depends On: 1784848 1784880
Blocks: 1784882 1784883
TreeView+ depends on / blocked
 
Reported: 2019-12-18 15:02 UTC by Ben Parees
Modified: 2020-01-07 17:55 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1784880
: 1784882 (view as bug list)
Environment:
Last Closed: 2020-01-07 17:55:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0014 None None None 2020-01-07 17:55:17 UTC

Description Ben Parees 2019-12-18 15:02:54 UTC
+++ This bug was initially created as a clone of Bug #1784880 +++

+++ This bug was initially created as a clone of Bug #1784848 +++

Description of problem:

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/24305/pull-ci-openshift-origin-master-e2e-cmd/2764

FAILURE after 60.000s: test/cmd/builds.sh:80: executing 'oc get is ruby-25-centos7' expecting any result and text 'latest'; re-trying every 0.2s until completion or 60.000s: the command timed out

88% of all cmd jobs failing with this:

https://search.svc.ci.openshift.org/chart?name=cmd&search=FAILURE.*executing.*ruby-25-centos7.*timed%20out


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from W. Trevor King on 2019-12-18 14:41:59 UTC ---

Disable in flight with [1].  This bug should track restoring the test and fixing whatever broke.

[1]: https://github.com/openshift/origin/pull/24319

--- Additional comment from Adam Kaplan on 2019-12-18 14:47:12 UTC ---

Root cause is that Software Collections is pushing a bunch of extra tags to Docker Hub, and the test implicitly assumed that only 2 (short) tags existed for that repo:

```
$ curl 'https://registry.hub.docker.com/v2/repositories/centos/ruby-25-centos7/tags/'|jq '."results"[]["name"]'
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1816  100  1816    0     0   7403      0 --:--:-- --:--:-- --:--:--  7412
"latest"
"20191217-a24b52d"
"2.5"
"20191128-7af5347"
```

Comment 2 wewang 2019-12-20 03:23:01 UTC
Check in version, no such issue
4.2.0-0.nightly-2019-12-20-010147

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-gcp-4.2/242

Comment 4 errata-xmlrpc 2020-01-07 17:55:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0014


Note You need to log in before you can comment on or make changes to this bug.