Bug 1785268 - wrong yaml dep level in release-4.2 branch
Summary: wrong yaml dep level in release-4.2 branch
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Michal Fojtik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On: 1785000
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-19 14:37 UTC by Neelesh Agrawal
Modified: 2019-12-30 07:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-30 07:34:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24331 None closed Bug 1785268: bump(*): pin ghodss/yaml 2020-02-14 09:03:03 UTC

Description Neelesh Agrawal 2019-12-19 14:37:03 UTC
This bug was initially created as a copy of Bug #1785000

I am copying this bug because: 



Description of problem:
see this thread:
https://coreos.slack.com/archives/CB48XQ4KZ/p1576696359066900

we seem to have the wrong dep level for ghodss/yaml.  it should be 
https://github.com/openshift/origin/blob/fe19c111f17f07c0351e1de31422e4fccbaa1735/glide.yaml#L141


it's causing unit test flakes as seen in
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/24325/pull-ci-openshift-origin-release-4.2-unit/89

Comment 2 Xingxing Xia 2019-12-30 07:34:12 UTC
From above desc, a dep issue, seems not an OCP functional issue, thus prefer to close it.


Note You need to log in before you can comment on or make changes to this bug.