Bug 1785289 - Deprecate Jenkins Pipeline Strategy
Summary: Deprecate Jenkins Pipeline Strategy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Gabe Montero
QA Contact: wewang
URL:
Whiteboard:
: 1789856 (view as bug list)
Depends On:
Blocks: 1785291
TreeView+ depends on / blocked
 
Reported: 2019-12-19 15:45 UTC by Adam Kaplan
Modified: 2020-05-04 11:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
Deprecated functionality should describe removed or no longer supported features. For this one, the docs were updated in 4.3: https://docs.openshift.com/container-platform/4.3/release_notes/ocp-4-3-release-notes.html#ocp-4-3-pipelines-now-deprecated This bug just updated the godocs for developers in the source code at https://github.com/openshift/api at https://github.com/openshift/api/blob/master/build/v1/types.go#L618
Clone Of:
: 1785291 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:20:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift api pull 574 0 None closed Bug 1785289: add deprecaction notice for build pipeline strategy 2020-04-22 18:28:13 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:21:18 UTC

Description Adam Kaplan 2019-12-19 15:45:10 UTC
Description of problem:

Pipeline build strategy is deprecated in OCP 4.3:
https://docs.openshift.com/container-platform/4.3/release_notes/ocp-4-3-release-notes.html#ocp-4-3-pipelines-now-deprecated

A notice should be added to the relevant API gdocs:
https://github.com/openshift/api/blob/master/build/v1/types.go#L617-L618


Version-Release number of selected component (if applicable): 4.3.0

Comment 1 Gabe Montero 2020-01-27 19:26:48 UTC
@wewang - as this is just a godoc change in openshift/api, I think we can move this straight to verify.

Comment 3 Gabe Montero 2020-02-03 18:23:28 UTC
*** Bug 1789856 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-05-04 11:20:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.