Bug 178537 - Heads order is not the same that under windows on dual-dvi PCIE X700
Heads order is not the same that under windows on dual-dvi PCIE X700
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-01-21 10:30 EST by Nicolas Mailhot
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 12:54:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5680 None None None Never

  None (edit)
Description Nicolas Mailhot 2006-01-21 10:30:33 EST
xorg does not detect the heads in the same order than windows on a dual-dvi PCIE
X700

This is very user-unfriendly, this means on a dual boot system one of the two
OSs won't display any image unless it's tweaked manually to change the primary
monitor (hooking something else on the secundary head to see what's you're doing
meanwhile.

Most users will decide the blank system is broken instaed of hunting and fixing
the problem
Comment 1 Nicolas Mailhot 2006-01-21 10:31:18 EST
More info in the xorg boog
Comment 2 Mike A. Harris 2006-01-23 12:54:35 EST
That's because the display detection code in X, is not the same code that
is used in ATI's proprietary driver in Windows.  In order for this to be
changed, it will have to be done upstream by X.Org, and my understanding
is that it will require a complete rewrite of the ATI display detection
code, which is a huge mess, making this particular feature request
nontrivial.

Feel free to file a feature request in upstream X.Org bugzilla if desired.

Comment 3 Nicolas Mailhot 2006-01-23 17:08:58 EST
Filled upstream as http://freedesktop.org/bugzilla/show_bug.cgi?id=5680

Note You need to log in before you can comment on or make changes to this bug.