Bug 178542 - rhythmbox refuses to play OGGs or MP3s
rhythmbox refuses to play OGGs or MP3s
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-21 10:56 EST by Eric Mesa
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 00:36:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Mesa 2006-01-21 10:56:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Whenever I try to play a song in rhythmbox, I get the following errors:

Internal GStreamer error: negotiation problem.  File a bug.
Internal GStreamer error: pad problem.  File a bug.
Could not start pipeline playing

Version-Release number of selected component (if applicable):
rhythmbox-0.8.8-2

How reproducible:
Always

Steps to Reproduce:
1.double-click on song or click play with a song selected in the playlist
2.
3.
  

Actual Results:  Those errors listed above appears

Expected Results:  a song should have played

Additional info:

went through a few steps with the team at Gnome and here's what we found:
-gstreamer is the RH version of gstreamer; from the Freshrpms repository I have also added gstreamer-plugins-extra-audio, extra-video, and tools-dvd;
-oggs can play in ogg123, xine, mplayer, xmms, and amaroK
-running st-launch-ext-0.8
01_Anberlin_Blueprints_For_The_Black_Market_Readyfuels.ogg
No configuration file /home/emesa/.gst found.  You might want to create one.
This is not an error, just a friendly reminder... Check the man page.

Running command-line
gst-launch-0.8 filesrc
location="01_Anberlin_Blueprints_For_The_Black_Market_Readyfuels.ogg" !
oggdemux ! vorbisdec ! audioconvert ! osssink

RUNNING pipeline ...
makes the song play - so gstreamer works
-I CAN listen to streaming media in rhythmbox
-finally, there is ONE mp3 that plays.  I tried playing other mp3s, but they don't work.  I tried other mp3s from the same folder - no dice.  I tried using the file command to see if there was a difference, but no - there wasn't.
-I have a lot of other programs that depend on the other gstreamer plugins, so I'd like to fix this w/o disturbing those, if possible.
Comment 1 Matthias Clasen 2006-11-27 00:36:20 EST
Thank you for the bug report. However, Fedora Project no longer maintains this
version of the product. Please upgrade to the latest version and open a new bug
if the problem persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older
releases, and if you believe this bug is interesting to them, please report the
problem against Fedora Legacy component


Note You need to log in before you can comment on or make changes to this bug.