Bug 178547 - enh: add yum / ssh to minimal install, and call it "base operating system"
enh: add yum / ssh to minimal install, and call it "base operating system"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-21 11:44 EST by David Timms
Modified: 2013-01-09 20:20 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 17:54:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2006-01-21 11:44:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
When no packages are selected for install ie the "base operating system", it would be good to have yum and ssh-client installed.

"Base operating system" is possibly a reasonably clear description for the minimal  package group. The current method of unselecting everything would suggest to many users that nothing would be installed!

Version-Release number of selected component (if applicable):
fc5t2

How reproducible:
Always

Steps to Reproduce:
1. in anaconda, unselect all packages.
2. when installer completes, boot system
3. #yum
  

Actual Results:  yum is not present (and hence life is unpleasant!)

Expected Results:  yum is installed and ready to rock'n'roll.

future: in installer, a group named "base operating system (kernel)", is the first item in the major group list, and this item cannot be deselected; it is the kernel and the system wont boot without it.
It has optional components including:
./ system-config-network (for wimps like me who don't want to remember the etc/ files to edit to config ip/subnet/router/dns).
./ ftp
./ mc (for vi cowards, and does ftp transfers)
./ rsync (to enable a freshly installed machine to get data from another machine easily)
./ slocate (is that file in this haystack ?)
./ ssh-client (i guess incudes sftp
./ yum

Also, the base-system ("~good for firewall / routers~") might have any duplicates of the above removed.

Additional info:

Including yum would make for much easier dep resolution as you add the particular packages that you want to the minimal install. How much bigger would absolute minimum be if yum (and :. dependencies) were included when no packages groups are selected ? (needs some python stuff)

see also: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=132682

(kernel) might be too scary for non-xperts.

While the packages can be (eventually) found in the other major groups or sub groups, selecting the group installs a heap of required stuff for that group, making the install much bigger than expected.

When such an enhancement is done, what other packages could be made easily available for similar minded folks ?
Comment 1 Jesse Keating 2006-01-25 17:54:29 EST
Without any selected, you get core, which is not base.  Core is about as minimal
as you can possibly go, add vim-minimal and rpm itself.  Base group has much
more included, including yum.
Comment 2 David Timms 2006-01-29 00:10:06 EST
> Without any selected, you get core, which is not base.

This is exactly what I meant: if a user selects "nothing" (unselects
everything), then it would make sense that nothing is what should be installed.
This is why I suggest a name change and behaviour change to "base operating
system"(required). That is what is internally called "core" (no user ever sees
this name), but should be visible to the user and it should not be possible to
deselect it since performing an install without it leads to an unbootable machine.

The "core" terminology is also confusing since it conflicts with "fedora core",
but are very different things!

Note You need to log in before you can comment on or make changes to this bug.