Bug 178555 - kmail cannot create folders on a dovecot IMAP server
Summary: kmail cannot create folders on a dovecot IMAP server
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-21 17:14 UTC by Vlado Potisk
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2006-05-03 12:55:39 UTC


Attachments (Terms of Use)

Description Vlado Potisk 2006-01-21 17:14:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
It is not possible to create a new email folder using the IMAP protocol on a dovecot powered server.

Version-Release number of selected component (if applicable):
kdepim-3.5.0-0.2.fc4

How reproducible:
Always

Steps to Reproduce:
1. right-click on an IMAP account and choose the "New subfolder" function
2. type in some folder name and click OK
  

Actual Results:  A long error message is displayed:
- - - - -
Error while creating a folder.
Could Not Create Folder
An attempt to create the requested folder failed.
....
- - - - -

Expected Results:  New email folder should have been created

Additional info:

I set the bug severity to high, because new users get only the inbox folder to handle all their mail.

This KDE bug report seems to describe the problem:
http://bugs.kde.org/show_bug.cgi?id=115254
tcpdump -A port imap command shows that a dot is prepended to the folder name:
CREATE ".newfolder"

Comment 1 Ngo Than 2006-05-03 12:55:39 UTC
it's fixed in kdepim-3.5.2, which is available in the FC5 update. Thanks for
your report.


Note You need to log in before you can comment on or make changes to this bug.