Bug 178576 - Firefox is se to ignore current locale by default
Firefox is se to ignore current locale by default
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-21 16:43 EST by Milan Kerslager
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 03:12:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2006-01-21 16:43:28 EST
Firefox is set to ignore current locale by default. Because Firefox 1.5 is not
multiligual, users (or admins) must install language extension to provide
localization. But because the Firefox is se to ignore current locale (by global
config), installed localization (by xpi file) is ignored and the user is forced
to go to "about:config" screen and force locale manually as the second step
after the langpack install.

So please add this line to /usr/lib/firefox-1.5/defaults/pref/firefox-l10n.js
file (this file is generated in the SPEC file so why not):

pref("intl.locale.matchOS", true);

After this, Firefox will be localized after the installation of the XPI file and
restarting to the same language as the current GUI environment. This allows to
install multiple languages and auto-switch the language as in the other
applications (and in the GUI). So this will harm nobody. Thank you.

To test, you may use Czech XPI file from here:
http://ftp.czilla.cz/mozilla.org/firefox/1.5/lang/firefox-1.5.cs.linux-i686.langpack.xpi
After the install, try to run firefox by: LANG=cs firefox
Comment 1 Rahul Sundaram 2006-02-20 05:40:51 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Matěj Cepl 2007-01-15 12:00:03 EST
Reporter, could you confirm please, that this bug still could be reproduced with
the latest release of Fedora (FC6)? It works for me without a glitch with both
FC6 and RHEL5b2.
Comment 3 Matthew Miller 2007-04-06 12:09:47 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]

Note You need to log in before you can comment on or make changes to this bug.