Bug 1785826 - startkde has gone
Summary: startkde has gone
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-workspace
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1785858 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-21 11:34 UTC by Ian Donaldson
Modified: 2020-01-13 02:19 UTC (History)
10 users (show)

Fixed In Version: plasma-workspace-5.17.5-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-13 02:19:53 UTC
bcotton: fedora_prioritized_bug?


Attachments (Terms of Use)

Description Ian Donaldson 2019-12-21 11:34:12 UTC
Description of problem:

/usr/bin/startkde no longer exists 

Version-Release number of selected component (if applicable):

plasma-workspace-5.17.4-1.fc31.x86_64


How reproducible:

try to login using kdm and a .Xclients file that I've had for 10+ years
that has exec /usr/bin/startkde on the last line

Steps to Reproduce:
1. dnf update
2. reboot
3. try to login; note you're back at the kdm login prompt

Actual results:

not logged in

Expected results:

logged in

Additional info:

Workaround; login using failsafe, then run these:

kwin &
plasmashell &

and things work pretty well.

/usr/bin/startkde existed in the prior package:

plasma-workspace-5.16.5-1.fc31.x86_64

Comment 1 Ian Donaldson 2019-12-21 12:16:15 UTC
tried: dnf downgrade plasma-workspace ... which resulted in /usr/bin/startkde returning,
but that didn't work; ksmserver died with an unresolved symbol.

running startkde from failsafe didn't work either, and neither did my workaround 
of running kwin and plasmashell by hand.

So re-upgraded; tried using kdm's 'plasma' session type; this resulted
in just a background fc31 image but no menus or any functionality; so 
I'm back to my workaround mentioned originally again.

Comment 2 Rex Dieter 2019-12-21 13:55:51 UTC
The latest plasma release did indeed change that to '/usr/bin/startplasma-x11', try that name instead

That said, logging in graphically should work too, no idea why you're only getting wallpaper.

Comment 3 Ian Donaldson 2019-12-21 22:19:10 UTC
I've modified my .Xclients to use /usr/bin/startplasma-x11  and that seems to work.

I'm puzzled as to why such a well known command would be suddenly renamed though, probably causing
lots of issues with others also.

BTW, xorg-x11-xinit-1.4.0-5.fc31.x86_64

still mentions startkde in /etc/X11/xinit/Xsession

Not sure about the wallpaper thing; plasma and kwin were both running; just not doing much.  I'll debug
that further...

Comment 4 Ben Cotton 2019-12-21 22:45:07 UTC
I created a symlink ( /usr/bin/startkde -> /usr/bin/startplasma-x11 ) and everything seems to work correctly after that. That may be the easiest approach to fixing it long term. Updating the xorg-x11-xinit package to replace startkde with startplasma-x11 would also work, but there may be other places that 'startkde' is expected to exist.

Nominating as a prioritized bug because this could potentially affect everyone who runs KDE.

Comment 5 Rex Dieter 2019-12-23 16:31:42 UTC
%changelog
* Mon Dec 23 2019 Rex Dieter <rdieter@fedoraproject.org> - 5.17.4-2
- provide compat /usr/bin/startkde symlink (#1785826, #1785973)

Comment 6 Fedora Update System 2019-12-23 19:43:39 UTC
FEDORA-2019-499b84d03f has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-499b84d03f

Comment 7 igiwatson 2019-12-24 19:21:09 UTC
This bug causes tigervnc-server to fail, as ~/.vnc/xstartup has,
exec /etc/X11/xinit/xinitrc

which has,
elif [ -f /etc/X11/xinit/Xclients ]; then

which has,
STARTKDE="$(type -p startkde)"

I am using KDE spin, so only KDE desktop loaded.
I note, rpms switchdesk, switchdesk-gui, directly reference 'startkde' in created user files, ~/.Xclients-default, ~/.Xclients-default

The soft link work around fixes the problem for me.

Comment 8 Michel Dänzer 2020-01-03 08:17:04 UTC
*** Bug 1785858 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2020-01-04 22:23:06 UTC
plasma-workspace-5.17.4-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-499b84d03f

Comment 10 Fedora Update System 2020-01-09 01:07:47 UTC
bluedevil-5.17.5-1.fc31, breeze-gtk-5.17.5-1.fc31, grub2-breeze-theme-5.17.5-1.fc31, kactivitymanagerd-5.17.5-1.fc31, kde-cli-tools-5.17.5-1.fc31, kde-gtk-config-5.17.5-1.fc31, kdecoration-5.17.5-1.fc31, kdeplasma-addons-5.17.5-1.fc31, kgamma-5.17.5-1.fc31, khotkeys-5.17.5-1.fc31, kinfocenter-5.17.5-1.fc31, kmenuedit-5.17.5-1.fc31, kscreen-5.17.5-1.fc31, kscreenlocker-5.17.5-1.fc31, ksshaskpass-5.17.5-1.fc31, ksysguard-5.17.5-1.fc31, kwayland-integration-5.17.5-1.fc31, kwin-5.17.5-1.fc31, kwrited-5.17.5-1.fc31, libkscreen-qt5-5.17.5-1.fc31, libksysguard-5.17.5-1.fc31, pam-kwallet-5.17.5-1.fc31, plasma-breeze-5.17.5-1.fc31, plasma-browser-integration-5.17.5-1.fc31, plasma-desktop-5.17.5-1.fc31, plasma-discover-5.17.5-1.fc31, plasma-drkonqi-5.17.5-1.fc31, plasma-integration-5.17.5-1.fc31, plasma-milou-5.17.5-1.fc31, plasma-nm-5.17.5-1.fc31, plasma-oxygen-5.17.5-1.fc31, plasma-pa-5.17.5-1.fc31, plasma-sdk-5.17.5-1.fc31, plasma-systemsettings-5.17.5-1.fc31, plasma-user-manager-5.17.5-1.fc31, plasma-vault-5.17.5-1.fc31, plasma-workspace-5.17.5-1.fc31, plasma-workspace-wallpapers-5.17.5-1.fc31, plymouth-kcm-5.17.5-1.fc31, plymouth-theme-breeze-5.17.5-1.fc31, polkit-kde-5.17.5-1.fc31, powerdevil-5.17.5-1.fc31, sddm-kcm-5.17.5-1.fc31, xdg-desktop-portal-kde-5.17.5-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-515c3c4b9d

Comment 11 alex.j.kerzner 2020-01-11 13:59:44 UTC
Adding that `switchdesk` should reference `/usr/bin/startplasma-x11` instead of '/usr/bin/startkde'. See `/usr/share/switchdesk/Xclients.kde`. This was already mentioned in a prior comment #7.

Comment 12 Fedora Update System 2020-01-13 02:19:53 UTC
bluedevil-5.17.5-1.fc31, breeze-gtk-5.17.5-1.fc31, grub2-breeze-theme-5.17.5-1.fc31, kactivitymanagerd-5.17.5-1.fc31, kde-cli-tools-5.17.5-1.fc31, kde-gtk-config-5.17.5-1.fc31, kdecoration-5.17.5-1.fc31, kdeplasma-addons-5.17.5-1.fc31, kgamma-5.17.5-1.fc31, khotkeys-5.17.5-1.fc31, kinfocenter-5.17.5-1.fc31, kmenuedit-5.17.5-1.fc31, kscreen-5.17.5-1.fc31, kscreenlocker-5.17.5-1.fc31, ksshaskpass-5.17.5-1.fc31, ksysguard-5.17.5-1.fc31, kwayland-integration-5.17.5-1.fc31, kwin-5.17.5-1.fc31, kwrited-5.17.5-1.fc31, libkscreen-qt5-5.17.5-1.fc31, libksysguard-5.17.5-1.fc31, pam-kwallet-5.17.5-1.fc31, plasma-breeze-5.17.5-1.fc31, plasma-browser-integration-5.17.5-1.fc31, plasma-desktop-5.17.5-1.fc31, plasma-discover-5.17.5-1.fc31, plasma-drkonqi-5.17.5-1.fc31, plasma-integration-5.17.5-1.fc31, plasma-milou-5.17.5-1.fc31, plasma-nm-5.17.5-1.fc31, plasma-oxygen-5.17.5-1.fc31, plasma-pa-5.17.5-1.fc31, plasma-sdk-5.17.5-1.fc31, plasma-systemsettings-5.17.5-1.fc31, plasma-user-manager-5.17.5-1.fc31, plasma-vault-5.17.5-1.fc31, plasma-workspace-5.17.5-1.fc31, plasma-workspace-wallpapers-5.17.5-1.fc31, plymouth-kcm-5.17.5-1.fc31, plymouth-theme-breeze-5.17.5-1.fc31, polkit-kde-5.17.5-1.fc31, powerdevil-5.17.5-1.fc31, sddm-kcm-5.17.5-1.fc31, xdg-desktop-portal-kde-5.17.5-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.