Bug 178598 - audacity doesn't build under current mock/devel due to compiler issues
audacity doesn't build under current mock/devel due to compiler issues
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-01-22 01:46 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-17 19:26:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log from failing mock build session (26.87 KB, text/plain)
2006-01-22 01:46 EST, Kevin Fenzi
no flags Details
fixes libsamplerate version check (2.03 KB, patch)
2006-02-22 16:57 EST, John Thacker
no flags Details | Diff
Fixes locale installation location (461 bytes, patch)
2006-02-22 16:59 EST, John Thacker
no flags Details | Diff
Fixes compilation with gcc41 ("extra qualification" issue) (673 bytes, patch)
2006-02-22 17:26 EST, John Thacker
no flags Details | Diff

  None (edit)
Description Kevin Fenzi 2006-01-22 01:46:58 EST
Description of problem:
Audacity doesn't build under current mock/devel. It gets what looks like a g++
error. Build.log attached. 

Version-Release number of selected component (if applicable): 1_2_3-5


How reproducible:
Try and build the package under current mock/devel, and it doesn't build.
Comment 1 Kevin Fenzi 2006-01-22 01:46:59 EST
Created attachment 123538 [details]
build.log from failing mock build session
Comment 2 Matthew Miller 2006-02-08 09:16:23 EST
I think we should update to 1.3.0 (beta) anyway -- this'll make it build with
wxGTK 2.6 instead of with the compat-wxGTK.
Comment 3 John Thacker 2006-02-22 16:57:47 EST
Created attachment 125065 [details]
fixes libsamplerate version check
Comment 4 John Thacker 2006-02-22 16:58:28 EST
I agree with updating to 1.3.0b.  I've built it myself-- note that there's a
little bit of brokeness in how its configure tests for libsamplerate (tests for
0.15.0 instead of 0.0.15) and in how it installs the locales.  Patches of my own
that seem to work provided.
Comment 5 John Thacker 2006-02-22 16:59:10 EST
Created attachment 125066 [details]
Fixes locale installation location
Comment 6 John Thacker 2006-02-22 17:21:54 EST
Of course, the "extra qualifications" bug is still there in 1.3.0b.  It has to
do with a change in gcc4.1.  It's also not that hard to fix the problem:  strip
off the soundtouch::SoundTouch:: from the member.
Comment 7 John Thacker 2006-02-22 17:26:14 EST
Created attachment 125068 [details]
Fixes compilation with gcc41 ("extra qualification" issue)
Comment 8 Michael Schwendt 2006-03-17 15:53:08 EST
I'm currently rebuilding audacity with the compat-wxGTK2-devel package
series, but that one is broken. So, stay tuned.
Comment 9 Michael Schwendt 2006-03-17 19:26:30 EST
Fixed in CVS and livna using the gtk1 wxGTK. Upstream has released 1.2.4b
(stable) some time ago and recommends not building against gtk2 wxGTK.
There are still various run-time issues with fonts/layout/behaviour and
even weird crashes in wxGTK. Initially, the package was stuck in fedora.us
QA due to severe crashes in gtk2 wxGTK, only later it was built and released
with gtk2 wxGTK, but there are still users who run into weird problems which
they claim do not occur when building with gtk1 wxGTK. So, pleasing upstream
is the slightly better choice, isn't it?

Audacity 1.3.x development is a jump to gtk2 wxGTK >= 2.6.1
Comment 10 Matthew Miller 2006-03-17 21:05:42 EST
Yeah, my impression is: wxGTK 2.4, use gtk1; wxGTK 2.6, use gtk2. Part of the
reason I'm eager to get everything to 2.6. :)

Note You need to log in before you can comment on or make changes to this bug.