Bug 1786008 - Broken gcc/sof-*.ri symlinks
Summary: Broken gcc/sof-*.ri symlinks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-firmware
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-23 04:45 UTC by John Dodson
Modified: 2020-06-14 17:10 UTC (History)
4 users (show)

Fixed In Version: alsa-firmware-1.2.1-6.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-14 17:10:22 UTC
Type: Bug


Attachments (Terms of Use)

Description John Dodson 2019-12-23 04:45:24 UTC
Description of problem:

/usr/lib/firmware/intel/sof/gcc/sof-apl.ri: broken symbolic link to signed/sof-apl-signed-intel.ri
alsa-firmware-1.2.1-3.fc31.noarch

/usr/lib/firmware/intel/sof/gcc/sof-icl.ri: broken symbolic link to signed/sof-icl-signed-intel.ri
alsa-firmware-1.2.1-3.fc31.noarch

/usr/lib/firmware/intel/sof/gcc/sof-cnl.ri: broken symbolic link to signed/sof-cnl-signed-intel.ri
alsa-firmware-1.2.1-3.fc31.noarch

Version-Release number of selected component (if applicable):
See above
alsa-firmware-1.2.1-3.fc31.noarch
How reproducible:

On machine with alsa
Steps to Reproduce:
1. ls -l /usr/lib/firmware/intel/sof/gcc/sof-cnl.ri etc.
2.
3.

Actual results:

Broken symlinks

Expected results:
No broken symlinks - appropriate maintenance of symlinks

Additional info:

Comment 1 Tim Jackson 2020-01-02 22:19:20 UTC
*** Bug 1787387 has been marked as a duplicate of this bug. ***

Comment 2 Tim Jackson 2020-01-02 22:22:27 UTC
Jaroslav, do you know what's going on here? The symlinks gcc/*.ri are broken in the sof tarball. Can we fix just by pointing them to ../signed/*.ri ?

Comment 3 Robert Hancock 2020-01-02 22:23:15 UTC
The issue in bug 1787387 is slightly different as the kernel is trying to load intel/sof/sof-cfl.ri which is not present at all, even as a broken symlink. There are no "cfl" files in alsa-firmware at all.

Comment 4 Tim Jackson 2020-01-02 22:26:05 UTC
Good point, thanks

Comment 5 Fedora Update System 2020-01-06 10:52:22 UTC
FEDORA-2020-534cccb6cb has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-534cccb6cb

Comment 6 Fedora Update System 2020-01-07 01:06:42 UTC
alsa-firmware-1.2.1-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-534cccb6cb

Comment 7 Fedora Update System 2020-01-08 11:55:24 UTC
alsa-firmware-1.2.1-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-06-01 16:04:14 UTC
FEDORA-2020-18cc548263 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-18cc548263

Comment 9 Fedora Update System 2020-06-02 04:00:25 UTC
FEDORA-2020-18cc548263 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-18cc548263`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-18cc548263

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-06-14 17:10:22 UTC
alsa-firmware-1.2.1-6.fc31, alsa-sof-firmware-1.5-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.