Bug 1786062 - 'oc describe' causes panic when describe a DC with HPA
Summary: 'oc describe' causes panic when describe a DC with HPA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1785513
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-23 09:43 UTC by Maciej Szulik
Modified: 2020-02-25 06:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1785513
Environment:
Last Closed: 2020-02-25 06:17:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 228 None closed [release-4.3] Bug 1786062: fix describe for HPA 2020-02-20 16:45:28 UTC
Red Hat Product Errata RHBA-2020:0528 None None None 2020-02-25 06:18:12 UTC

Comment 2 zhou ying 2020-02-13 05:22:54 UTC
Confirmed with latest oc client, the issue has fixed:
[zhouying@dhcp-140-138 ~]$ oc version -o yaml
clientVersion:
  buildDate: "2020-02-12T17:56:47Z"
  compiler: gc
  gitCommit: 1d7211968ceb449852d10d12eae92ed5c33d8b48
  gitTreeState: clean
  gitVersion: v4.3.2
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64


[zhouying@dhcp-140-138 ~]$ oc describe dc ruby-ex
Name:		ruby-ex
Namespace:	zhouyt
Created:	36 seconds ago
Labels:		app=ruby-ex
		app.kubernetes.io/component=ruby-ex
		app.kubernetes.io/instance=ruby-ex
Annotations:	openshift.io/generated-by=OpenShiftNewApp
Latest Version:	Not deployed
Selector:	deploymentconfig=ruby-ex
Replicas:	1
Autoscaling:	between 1 and 10 replicas targeting 50% CPU over all the pods
Triggers:	Config, Image(ruby-ex@latest, auto=true)
Strategy:	Rolling
...

Comment 4 errata-xmlrpc 2020-02-25 06:17:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0528


Note You need to log in before you can comment on or make changes to this bug.