Bug 1786251 - remove retry link from the 'access review' page for normal user
Summary: remove retry link from the 'access review' page for normal user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-24 05:43 UTC by shahan
Modified: 2020-07-13 17:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Users without permissions could see the Review Access tabs in the Explorer section. Consequence: User would see confusing error message and ask them to 'try again' on that page even though they had no permissions Fix: The Review Access tab is no longer shown for users who do not have the proper authorization. Result: Users do not see the Review Access tab and cannot see the error message that was previously confusing and misleading
Clone Of:
Environment:
Last Closed: 2020-07-13 17:12:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5352 None closed Bug 1786251: Add Access Denied error handling on Access Review 2020-06-23 08:19:28 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:13:19 UTC

Description shahan 2019-12-24 05:43:08 UTC
Description of problem:
 remove retry link from the 'access review' page

Version-Release number of selected component (if applicable):
     4.3.0-0.nightly-2019-12-22-223447

How reproducible:
always

Steps to Reproduce:
1. general user click Home-> explore -> Node -> access review
2.
3.

Actual results:
Error Loading Access Review: resourceaccessreviews.authorization.openshift.io is forbidden: User "testuser-0" cannot create resource "resourceaccessreviews" in API group "authorization.openshift.io" at the cluster scope
Please try again.

Expected results:
Should remove the 'try again 'link

Additional info:

Comment 1 Zac Herman 2020-05-08 16:47:52 UTC
Have a PR open and hope to merge a fix next sprint

Comment 4 shahan 2020-05-09 04:41:34 UTC
The access review disabled for general user
4.5.0-0.nightly-2020-05-09-003922

Comment 6 errata-xmlrpc 2020-07-13 17:12:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.