Bug 1786259 - "Edit YAML" leads to 404 error on Create NAD page
Summary: "Edit YAML" leads to 404 error on Create NAD page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Phillip Bailey
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-24 06:18 UTC by Guohua Ouyang
Modified: 2020-05-04 11:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:21:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
nad edit (21.88 KB, image/png)
2019-12-24 06:18 UTC, Guohua Ouyang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3880 None closed Bug 1786259: Fix Edit YAML link on NAD creation page 2020-03-05 10:09:58 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:21:47 UTC

Description Guohua Ouyang 2019-12-24 06:18:25 UTC
Created attachment 1647451 [details]
nad edit

Description of problem:
There is an "Edit YAML" on Create NAD page, click the button leads to a 404 page.
The button should be removed.

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-19-050538

How reproducible:
100%

Steps to Reproduce:
1.In the web console, click Networking → Network Attachment Definitions.
2. Click Create Network Attachment Definition .
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tomas Jelinek 2020-01-06 12:30:14 UTC
Actually the "edit yaml" button should still be there, just clicking it should not lead to 404 but to the yaml editor.

Comment 2 Guohua Ouyang 2020-01-07 02:56:44 UTC
Just checked other pages, like storage class, it has "edit yaml" as well. So it's okay to have this button.
Then it just needs to fix the 404 issue.

Comment 7 errata-xmlrpc 2020-05-04 11:21:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.