Bug 17863 - gnome-terminal and netscape (at least) do not show title
gnome-terminal and netscape (at least) do not show title
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: enlightenment (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-26 13:59 EDT by ivan
Modified: 2013-04-02 00:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-26 19:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ivan 2000-09-26 13:59:43 EDT
gnome-terminal -t TITLE
Does not show a title on the terminal window. Neither is there one as a
default (which there used to be.

Netscape also does not show a title. This worked OK in v6.95 (7.0 beta).
Comment 1 David Mason 2000-09-26 14:18:53 EDT
Are you getting titles for anything? I have tried this on a couple of clean
installs and it works fine. Which window manager
are you using? Make sure you have no theme or settings that are blowing this
away. Also, for the terminal if you are overriding
the title with PS1 settings in your .bashrc you will never get this to work.
Comment 2 ivan 2000-09-26 14:34:22 EDT
I am using Enlightenment as a window manager. It doesn't look like I am getting
titles for any window. It also looks like I can't run the enlightenment config
tool (the button is greyed out in the "window manager" config).

I guess it is something to go with enlightenment. I tried moving my
~/.enlightenment dir, before starting X, but this made no difference.

FWIW, this install is an upgrade from 6.95 (which was working OK). Perhaps it
should be logged as a "problem with enlightenment"?
Comment 3 ivan 2000-09-26 14:48:52 EDT
Update:
Backing out to enlightenment from RedHat 6.95 does not fix it. Moving the
following dirs aside:
~/.enlightenment
~/.gnome*
and starting X, then changing to enlightenment WM makes no difference (still no
windows). Neither moving the dirs, nor backing out to the older enlightenment
RPM allows me to run the Enlightenment config (from the "control center").
Comment 4 David Mason 2000-09-26 15:06:34 EDT
So are you using the New Enlightenment - 0.16*? Of course as the update script
should have told you when updating from 6.2 we have moved to sawfish for the
default wm for GNOME. E does not work well with GNOME now but is fine as a
standalone desktop. Things like the config tool are gone and are now divided
into many dialogs reached by the root menu items.

Unless you are very attached to E you might try using sawfish. I will change
this to an E bug and assign however as my best guess is that it lies in there
somewhere.
Comment 5 ivan 2000-09-26 19:27:07 EDT
I am using the new Enlightenment (that came with RedHat Linux 7.0) although, 
as I said, I tried using the one from RedHat v6.95, and that made no difference
(but an install of RedHat Linux v6.95 did not exhibit this problem).

I noticed that you are pusing sawfish more but, as E used to be your "desktop of
choice" for RedHat Linux, that is the one I have gotten used to using. I was
intending to look at Sawfish more when I got the chance (after 7.0).

I noticed in RedHat 6.95, that there were several config items off the root
menu, but I can no longer get _any_ menus in E (as per above - neither in the
version that comes with v7.0 or v6.95), yet it worked find with a full install
of v6.95.

Following your initial comment, I thought this was an E "bug", but now I am
wondering whether it is a gnome buglet :(

That said, it is likely to be something to do with interaction between E and
gnome, which the E maintainer at RedHat may see better.

Note You need to log in before you can comment on or make changes to this bug.