Bug 1786364 - [4.2] [IPI on Azure] interactive installer lists non available regions
Summary: [4.2] [IPI on Azure] interactive installer lists non available regions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.3.z
Assignee: Fabiano Franz
QA Contact: Etienne Simard
URL:
Whiteboard:
Depends On: 1808464
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-24 17:03 UTC by Etienne Simard
Modified: 2020-04-08 07:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1786363
Environment:
Last Closed: 2020-04-08 07:39:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3320 None closed [release-4.3] Bug 1786364: filter out unsupported regions in Azure 2020-04-03 17:30:35 UTC
Red Hat Product Errata RHBA-2020:1262 None None None 2020-04-08 07:40:03 UTC

Description Etienne Simard 2019-12-24 17:03:32 UTC
+++ This bug was initially created as a clone of Bug #1786363 +++

Description of problem:

Using the IPI on Azure interactive installer, it lists regions that are not available in your subscription. 


How reproducible: Always

Steps to Reproduce:

1. Run the Azure interactive installer
2. Record the list of regions from the interactive installer


Actual results:

~~~
...
australiacentral (Australia Central)
  australiacentral2 (Australia Central 2)
  australiaeast (Australia East)
  australiasoutheast (Australia Southeast)
  brazilsouth (Brazil South)
  canadacentral (Canada Central)
  canadaeast (Canada East)
  centralindia (Central India)
  centralus (Central US)
  eastasia (East Asia)
> eastus (East US)
  eastus2 (East US 2)
  francecentral (France Central)
  francesouth (France South)
 germanynorth (Germany North)
  germanywestcentral (Germany West Central)
> japaneast (Japan East)
  japanwest (Japan West)
  koreacentral (Korea Central)
  koreasouth (Korea South)
 northcentralus (North Central US)
  northeurope (North Europe)
  norwayeast (Norway East)
> norwaywest (Norway West)
  southafricanorth (South Africa North)
  southafricawest (South Africa West)
  southcentralus (South Central US)
southindia (South India)
  switzerlandnorth (Switzerland North)
> switzerlandwest (Switzerland West)
  uaecentral (UAE Central)
  uaenorth (UAE North)
  uksouth (UK South)
  ukwest (UK West)
  westcentralus (West Central US)
  westeurope (West Europe)
> westindia (West India)
  westus (West US)
  westus2 (West US 2)
...
~~~

If you choose a non-available region from that list, your install will fail with the following error:

level=error msg="Error: Error creating resource group: resources.GroupsClient#CreateOrUpdate: Failure responding to request: StatusCode=400 -- Original Error: autorest/azure: Service returned an error. Status=400 Code=\"LocationNotAvailableForResourceGroup\" Message=\"The provided location 'australiacentral2' is not available for resource group. List of available regions is 
'centralus,eastasia,southeastasia,eastus,eastus2,westus,westus2,northcentralus,southcentralus,westcentralus,northeurope,westeurope,japaneast,japanwest,
brazilsouth,australiasoutheast,australiaeast,westindia,southindia,centralindia,canadacentral,canadaeast,
uksouth,ukwest,koreacentral,koreasouth,francecentral,southafricanorth,uaenorth,australiacentral,germanywestcentral'.\""

Expected results:

Only list the same regions from the List of available regions so the customer cannot run into this error.

Comment 3 Etienne Simard 2020-03-31 13:24:05 UTC
Verified with:

./openshift-install v4.3.9
built from commit 0a7f198c1d5667152ef5982fd2fc0c22abc4336f
release image registry.svc.ci.openshift.org/ocp/release@sha256:72d86abb1602fefadc712a71af9cceb64194cd4cc8fabe0cea6d6d9ff412aa92

Regions:

? Region  [Use arrows to move, enter to select, type to filter, ? for more help]
> australiacentral (Australia Central)
  australiaeast (Australia East)
  australiasoutheast (Australia Southeast)
  brazilsouth (Brazil South)
  canadacentral (Canada Central)
  canadaeast (Canada East)
  centralindia (Central India)
  centralus (Central US)
  eastasia (East Asia)
  eastus (East US)
> eastus2 (East US 2)
  francecentral (France Central)
  germanywestcentral (Germany West Central)
  japaneast (Japan East)
  japanwest (Japan West)
  koreacentral (Korea Central)
  koreasouth (Korea South)
> northcentralus (North Central US)
  northeurope (North Europe)
  norwayeast (Norway East)
  southafricanorth (South Africa North)
  southcentralus (South Central US)
  southeastasia (Southeast Asia)
  southindia (South India)
> switzerlandnorth (Switzerland North)
  uaenorth (UAE North)
  uksouth (UK South)
  ukwest (UK West)
  westcentralus (West Central US)
  westeurope (West Europe)
  westindia (West India)
> westus (West US)
  westus2 (West US 2)

Logs:

~~~
./openshift-install create cluster --dir ./test1
? SSH Public Key /home/openshift-qe/.ssh/id_rsa.pub
? Platform azure
? Region eastus
? Base Domain qe.openshift.com
? Cluster Name esstest01
? Pull Secret [? for help] ***************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************INFO Creating infrastructure resources...         
INFO Waiting up to 30m0s for the Kubernetes API at https://api.esstest01.qe.openshift.com:6443... 
INFO API v1.16.2 up                               
INFO Waiting up to 30m0s for bootstrapping to complete... 
INFO Destroying the bootstrap resources...        
INFO Waiting up to 30m0s for the cluster at https://api.esstest01.qe.openshift.com:6443 to initialize... 
INFO Waiting up to 10m0s for the openshift-console route to be created... 
INFO Install complete!                            
INFO To access the cluster as the system:admin user when using 'oc', run 'export KUBECONFIG=/home/openshift-qe/TESTS/bugzilla/1786364/test1/auth/kubeconfig' 
INFO Access the OpenShift web-console here: https://console-openshift-console.apps.esstest01.qe.openshift.com 
INFO Login to the console with user: kubeadmin, password: ...
~~~

Comment 4 Etienne Simard 2020-03-31 14:52:52 UTC
Also verified with:

./openshift-install v4.3.10
built from commit 0a7f198c1d5667152ef5982fd2fc0c22abc4336f
release image registry.svc.ci.openshift.org/ocp/release@sha256:5bb5ef1336214c8c04381fbde7514a5547db2437879b75608d7e8337728e2e3c

Comment 6 errata-xmlrpc 2020-04-08 07:39:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1262


Note You need to log in before you can comment on or make changes to this bug.