Bug 1786418 - The filter does not work on catalog sources list page
Summary: The filter does not work on catalog sources list page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-25 05:35 UTC by shahan
Modified: 2020-05-04 11:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Goto Administration->cluster setting->Global configuration ->OperatorHub Details->Source Tab Input source name in the filter textbox. Consequence: The page show error: Oh no! Something went wrong Fix: Updated code to use 'obj.name', not 'obj.metadata.name' as found in most k8s resource tables' Result: Text filtering now works on Administration->cluster setting->Global configuration ->OperatorHub Details->Source Tab
Clone Of:
Environment:
Last Closed: 2020-05-04 11:21:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3897 0 None closed Bug 1786418: The filter does not work on catalog sources list page 2020-07-29 00:37:20 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:22:08 UTC

Description shahan 2019-12-25 05:35:00 UTC
Description of problem:
The filter does not work on catalog sources list page

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-24-221900

How reproducible:
always

Steps to Reproduce:
1. Goto Administration->cluster setting->Global configuration ->OperatorHub Details->Source Tab
2. input source name in the filter textbox
3.

Actual results:
2. The page show error: Oh no! Something went wrong.
Cannot read property 'name' of undefined

Expected results:
the filter textbox should works well

Additional info:
TypeError: Cannot read property 'name' of undefined
    at name (https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/main-chunk-ce18ff88fa53212e782b.min.js:1:121200)
    at https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/main-chunk-ce18ff88fa53212e782b.min.js:1:282181
    at t.a (https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/vendors~main-chunk-516ca37cfac5543aa3fb.min.js:12:191334)
    at Object.t.a (https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/vendors~main-chunk-516ca37cfac5543aa3fb.min.js:12:137851)
    at https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/main-chunk-ce18ff88fa53212e782b.min.js:1:282158
    at https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/vendors~main-chunk-516ca37cfac5543aa3fb.min.js:30:126267
    at t.a (https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/vendors~main-chunk-516ca37cfac5543aa3fb.min.js:12:177975)
    at https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/vendors~main-chunk-516ca37cfac5543aa3fb.min.js:30:126032
    at Object.t.a (https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/vendors~main-chunk-516ca37cfac5543aa3fb.min.js:12:94000)
    at https://console-openshift-console.apps.qe-ui-12250831.qe.devcluster.openshift.com/static/main-chunk-ce18ff88fa53212e782b.min.js:1:282116

Comment 2 David Taylor 2020-01-08 16:52:44 UTC
Was able to reproduce:

TypeError
Description:
Cannot read property 'name' of undefined

Component Trace:
in ConnectFunction (created by CatalogSourceList)
    in CatalogSourceList (created by ListPageWrapper_)
    in div (created by ListPageWrapper_)
    in div (created by ListPageWrapper_)
    in div (created by ListPageWrapper_)
    in ListPageWrapper_ (created by MultiListPage)
    in Unknown
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Firehose)
    in Firehose (created by ConnectFunction)
    in ConnectFunction (created by MultiListPage)
    in div (created by ConnectedFireMan)
    in ConnectedFireMan (created by ConnectFunction)
    in ConnectFunction
    in ConnectFunction (created by MultiListPage)
    in MultiListPage (created by CatalogSourceListPage)
    in CatalogSourceListPage (created by Sources)
    in Sources (created by Context.Consumer)
    in Route
    in Switch
    in div (created by Data)
    in Data (created by StatusBox)
    in StatusBox
    in div
    in div
    in Unknown
    in Unknown
    in Unknown
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Firehose)
    in Firehose (created by ConnectFunction)
    in ConnectFunction
    in Unknown (created by DetailsPage)
    in ErrorBoundary (created by DetailsPage)
    in DetailsPage (created by OperatorHubDetailsPage)
    in OperatorHubDetailsPage (created by AsyncComponent)
    in AsyncComponent
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Context.Consumer)
    in Route (created by AppContents_)
    in Switch (created by AppContents_)
    in div (created by AppContents_)
    in div (created by AppContents_)
    in section (created by PageSection)
    in PageSection (created by AppContents_)
    in AppContents_ (created by ConnectFunction)
    in ConnectFunction (created by ConnectFunction)
    in ConnectFunction (created by App)
    in main (created by Page)
    in div (created by Page)
    in Page (created by App)
    in App (created by Context.Consumer)
    in Route
    in Router
    in Provider

Comment 4 shahan 2020-01-13 02:51:33 UTC
The filter works well on catalog sources list page

4.4.0-0.nightly-2020-01-12-221811

Comment 6 errata-xmlrpc 2020-05-04 11:21:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.