Bug 178645 - ACPI events delayed; buffered?
ACPI events delayed; buffered?
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-22 20:25 EST by Adrian Offerman
Modified: 2015-03-04 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 08:31:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Offerman 2006-01-22 20:25:27 EST
Description of problem:
After upgrading the kernel (and other packages) of my FC4 installation, ACPI
events are no longer immediately coming through. They are delayed or "pushed
out" after new events are generated. It appears as if they are buffered.

Version-Release number of selected component (if applicable):
Since the acpid package hasn't been updated since the FC4 release (still
1.0.4-1), I assume it's a kernel problem.
Kernels I tried, that are showing this problem: version 2.6.14-1.1656,
2.6.15-1.1824_2+swsusp2, and 2.6.11-1.1369.
There was one kernel package that I was running that didn't have this problem. I
don't know it's exact version; I think it's release number was ending with ..44

How reproducible:
Always.

Steps to Reproduce:
Generate ACPI events by pressing hotkeys. Then actions and logs in
/var/log/acpid are delayed.
  
Additional info:
I'm running FC4 on an Asus V6V notebook.
Comment 1 Adrian Offerman 2006-01-27 16:15:20 EST
This problem appears to be caused by the infamous ACPI EC burst mode, being
enabled and disabled again in the kernel. Several others using Asus notebooks
were experiencing similar problems. I've set kernel parameter ec_burst=1, and
things seem to run without any problems now.
Comment 2 Phil Knirsch 2006-02-10 08:31:46 EST
OK, as there isn't a lot i can do about this in userland and there is a know
workaround now i'm closing this bug.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.