Bug 1786591 - Add capacity from UI: Storage Class selection is missing [NEEDINFO]
Summary: Add capacity from UI: Storage Class selection is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.2.z
Assignee: Kanika Murarka
QA Contact: Elad
URL:
Whiteboard:
Depends On: 1769716
Blocks: 1787547
TreeView+ depends on / blocked
 
Reported: 2019-12-26 11:07 UTC by Gil Klein
Modified: 2020-01-22 10:46 UTC (History)
8 users (show)

Fixed In Version: 4.2.0-0.nightly-2020-01-10-024859
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1787547 (view as bug list)
Environment:
Last Closed: 2020-01-22 10:46:40 UTC
Target Upstream Version:
etamir: needinfo? (gklein)
afrahman: needinfo? (eparis)


Attachments (Terms of Use)
Firefox (92.83 KB, image/jpeg)
2019-12-26 11:07 UTC, Gil Klein
no flags Details
Chrome (81.49 KB, image/jpeg)
2019-12-26 11:08 UTC, Gil Klein
no flags Details
verification (594.46 KB, video/webm)
2020-01-16 07:15 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3843 None closed Bug 1786591: Shows the values in expand modal dropdown 2020-03-06 05:34:58 UTC
Red Hat Product Errata RHBA-2020:0107 None None None 2020-01-22 10:46:57 UTC

Description Gil Klein 2019-12-26 11:07:19 UTC
Created attachment 1647739 [details]
Firefox

Description of problem:
When trying to increase capacity via the OpenShift Container Storage operator, the storage class selection is missing
 

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-12-23-132554

oc describe pod -n openshift-storage ocs-operator-64dcff8966-4wccd |grep Image
    Image:         quay.io/rhceph-dev/ocs-operator:4.2-276.88017e9.release_4.2
    Image ID:      quay.io/rhceph-dev/ocs-operator@sha256:50d9005557ec23ccf1fa18ec5dbf2cc251e6ab57ab7263929e8044f6f6d85cd5

Firefox Version 71.0 Build ID 	20191202093317

Chrome Version 79.0.3945.88 (Official Build) (64-bit)


How reproducible:
100% in both Chrome and Firefox

Steps to Reproduce:
Go to
1. Installed Operators 
2. OpenShift Container Storage
3. Select project: openshift-storage
4. Click: Add Capacity 


Actual results:
Storage Class selection is missing

Expected results:
The Storage Class section should display a drop down menu


Additional info:

Comment 1 Gil Klein 2019-12-26 11:08:01 UTC
Created attachment 1647740 [details]
Chrome

Comment 2 Eran Tamir 2019-12-26 11:24:26 UTC
@Gil - I see that it happens with OCP nightly. Does it happen with the latest zstream?

Comment 4 afrahman 2020-01-07 04:06:48 UTC
This bug is required only for 4.2.z in 4.3 the code is refactored and the bug does not happens there.
What should be done in this case ?

Thanks!

Comment 8 Elad 2020-01-16 07:15:15 UTC
storageclass dropdown exists in add capacity prompt with 4.2.0-0.nightly-2020-01-14-110551

Comment 9 Elad 2020-01-16 07:15:54 UTC
Created attachment 1652646 [details]
verification

Comment 11 errata-xmlrpc 2020-01-22 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0107


Note You need to log in before you can comment on or make changes to this bug.