Bug 178662 - compat-wxGTK doesn't build under mock/devel due to unpackaged files
compat-wxGTK doesn't build under mock/devel due to unpackaged files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compat-wxGTK (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-01-22 22:46 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 17:47:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-01-22 22:46:00 EST
Description of problem:
compat-wxGTK doesn't build under mock/devel due to unpackaged files. 
Note until a recent fix mock/buildsys didn't fail building on unpackaged files. 

Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/compat-wxGTK-2.4.2-16.fc5-root-mockbuild
error: Installed (but unpackaged) file(s) found:
   /usr/lib/wx/include/gtk2-2.4/wx/setup.h


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/lib/wx/include/gtk2-2.4/wx/setup.h
Comment 1 Tom "spot" Callaway 2006-01-23 14:01:21 EST
OK, this is odd.

When I look at the compat-wxGTK2-devel package generated by the buildsystem, I see:

[spot@localhost compat-wxGTK]$ rpm -ql compat-wxGTK2-devel
/usr/bin/wxgtk2-2.4-config
/usr/lib/libwx_gtk2-2.4.so
/usr/lib/libwx_gtk2_gl-2.4.so
/usr/lib/libwx_gtk2_stc-2.4.so
/usr/lib/libwx_gtk2_xrc-2.4.so
/usr/lib/wx/include/gtk2-2.4
/usr/lib/wx/include/gtk2-2.4/wx
/usr/lib/wx/include/gtk2-2.4/wx/setup.h

In the %files section for compat-wxGTK2-devel, it looks like this:

%files -n %{name}2-devel
%defattr(-,root,root,-)
%ghost %{_bindir}/wx-2.4-config
%{_bindir}/wxgtk2-*-config
%{_libdir}/libwx_gtk2[-_]*.so
%{_libdir}/wx/include/gtk-2*

The last line is the line that includes the setup.h file... is this failure
specific to some architecture? Are globs failing in mock?
Comment 2 Kevin Fenzi 2006-01-24 13:32:19 EST
Took me a bit looking at it... but: 

%{_libdir}/wx/include/gtk-2*

doesn't match: 

/usr/lib/wx/include/gtk2-2.4/wx/setup.h

The - is in the wrong place. I think you want: 
%{_libdir}/wx/include/gtk2-*

ie, 

diff -r1.2 compat-wxGTK.spec
291c291
< %{_libdir}/wx/include/gtk-2*
---
> %{_libdir}/wx/include/gtk2-*
Comment 3 Tom "spot" Callaway 2006-08-22 17:47:18 EDT
compat-wxGTK built fine in the buildsystem today, closing out this bug.

Note You need to log in before you can comment on or make changes to this bug.