Bug 178665 - cone doesn't build under mock/devel due to compiler issues
cone doesn't build under mock/devel due to compiler issues
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cone (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-01-22 22:56 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.66.20060203-1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 18:34:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock build.log with compile failure (167.04 KB, text/plain)
2006-01-22 22:56 EST, Kevin Fenzi
no flags Details

  None (edit)
Description Kevin Fenzi 2006-01-22 22:56:41 EST
Description of problem:
cone doesn't build under mock/devel due to compiler issues.
Possibly g++ changes. 

Compiling cursesbutton.C
mycurses.H:240: error: extra qualification 'Curses::' on member 'wtomb'
mycurses.H:240: error: extra qualification 'Curses::' on member 'wtomb'
make[3]: *** [cursesbutton.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [curses.o] Error 1
make[3]: Leaving directory `/builddir/build/BUILD/cone-0.65/curses'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/builddir/build/BUILD/cone-0.65/curses'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/cone-0.65'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.82082 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.82082 (%build)

Full mock build.log attached.
Comment 1 Kevin Fenzi 2006-01-22 22:56:41 EST
Created attachment 123562 [details]
mock build.log with compile failure
Comment 2 Steven Pritchard 2006-02-11 19:01:40 EST
Should be fixed in CVS.  The current version builds fine for me under mock, but
failed in the buildsystem with "libtool: link: `libhmac.la' is not a valid
libtool archive".

I'll try again in the mass rebuild (tomorrow?).

Note You need to log in before you can comment on or make changes to this bug.