Bug 178669 - Moving a directory causes nautilus crash and kernel fault.
Moving a directory causes nautilus crash and kernel fault.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-22 23:30 EST by John Courie II
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 10:41:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Courie II 2006-01-22 23:30:48 EST
When moving files from usb hdd mounted at /media/disk to /home/<foo> 
after a few moments the nautilus window crashes.  When nautilus is launched from
a window this is the output after the crash: 

"rejecting I/O to dead device"


Environment:

Fedora Core 5 test 2 
Linux version 2.6.15-1.1826.2.10_FC5 (bhcompile@hs20-bc1-1.build.redhat.com)
(gcc version 4.1.0 20060106 (Red Hat 4.1.0-0.14)) #1 Wed Jan 11 18:12:42 EST 2006

USB Mass Storage support registered.
usb-storage: device scan complete
  Vendor: Maxtor 6  Model: L100P0            Rev: BAH4
  Type:   Direct-Access                      ANSI SCSI revision: 00
 

Nautilus is: 2.13.3


How reproducible:  Select a directory located in /media/disk and cut or copy it
and then paste it to /home/you/<foo>
Comment 1 John Courie II 2006-01-22 23:32:16 EST
Also, The Storage Device is not dead - and comes back on line after rebooting.

Comment 2 Alexander Larsson 2006-01-23 04:07:28 EST
Exactly how does the kernel fault? Does the usb drive just not work anymore, or
does more things happen?
Comment 3 Rahul Sundaram 2006-02-20 05:47:07 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Alexander Larsson 2006-09-04 11:56:15 EDT
I still don't understand exactly what happens, could you describe the problem in
a bit more detail? You say it comes back after rebooting, does that mean it
actually goes offline when nautilus crashes.

What is the backtrace from nautilus when it crashes?

Does copying the file with cp work? 

Do you get any logs in /var/log/messages when this happens?
Comment 5 John Courie II 2006-09-04 18:52:11 EDT
The bug has not manifested in the later releases of fc5 

cp did work, it crashed when nautilus was used. 

Note You need to log in before you can comment on or make changes to this bug.