Bug 1786732 - Review Request: python-pyhocon - module and utilitiy to read hocon and convert between yaml, json and properties
Summary: Review Request: python-pyhocon - module and utilitiy to read hocon and conver...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-27 14:31 UTC by Martin Jackson
Modified: 2021-02-06 17:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-02 03:04:58 UTC
Type: ---


Attachments (Terms of Use)

Description Martin Jackson 2019-12-27 14:31:34 UTC
Spec URL: https://copr.fedorainfracloud.org/coprs/mhjacks/mhjacks_proposed_pkgs/build/1135626/
SRPM URL: https://copr.fedorainfracloud.org/coprs/mhjacks/mhjacks_proposed_pkgs/build/1135626/
Description: module and utilitiy to read hocon and convert between yaml, json and properties
Fedora Account mhjacks

Comment 1 Robert-André Mauchin 🐧 2019-12-27 22:48:36 UTC
 - Fix this:

Summary:        Example python module


 - Source is 404:

Getting https://files.pythonhosted.org/packages/source/p/pyhocon/pyhocon-0.3.53.tar.gz to ./pyhocon-0.3.53.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404


 Use the Source from Github, Pypi seems unreliable on this.

Source0:        https://github.com/chimpler/pyhocon/archive/%{version}/%{name}-%{version}.tar.gz

 - Same as before, just name the main package pyhocon since it's a binary

 - Generate the docs:

BuildRequires:  python3-devel
BuildRequires:  python3dist(pyparsing)
BuildRequires:  python3dist(python-dateutil)
BuildRequires:  python3dist(mock)
BuildRequires:  python3dist(pytest)
BuildRequires:  python3dist(sphinx)

[…]


# generate html docs
PYTHONPATH=${PWD} sphinx-build-3 docs/source html
# remove the sphinx-build leftovers
rm -rf html/.{doctrees,buildinfo}

 - Tests fail on Python 3.8 (Rawhide): report the errors upstream and wait for them to release a version compatible with Python 3.8





%global srcname pyhocon

Name:           %{srcname}
Version:        0.3.53
Release:        2%{?dist}
Summary:        Example python module

License:        ASL 2.0
URL:            https://pypi.python.org/pypi/pyhocon
Source0:        https://github.com/chimpler/pyhocon/archive/%{version}/%{name}-%{version}.tar.gz

BuildArch:      noarch
BuildRequires:  python3-devel
BuildRequires:  python3dist(pyparsing)
BuildRequires:  python3dist(python-dateutil)
BuildRequires:  python3dist(mock)
BuildRequires:  python3dist(pytest)
BuildRequires:  python3dist(sphinx)

%global _description %{expand:
pyhocon is a HOCON parser for Python. Additionally we provide a tool
(pyhocon) to convert any HOCON content into json, yaml and properties
format.}

%description %_description

%prep
%autosetup -n %{srcname}-%{version}

%build
%py3_build
# generate html docs
PYTHONPATH=${PWD} sphinx-build-3 docs/source html
# remove the sphinx-build leftovers
rm -rf html/.{doctrees,buildinfo}

%install
%py3_install

%check
%{__python3} setup.py test

%files
%license LICENSE
%doc CHANGELOG.md README.md html/
%{python3_sitelib}/%{srcname}-*.egg-info/
%{python3_sitelib}/%{srcname}/
%{_bindir}/pyhocon

%changelog
* Sun Dec 22 2019 Martin Jackson <mhjacks@swbell.net> - 0.3.53-2
- Fixed license designation
- Specified module deps as BuildRequires
- Re-enabled %check

* Fri Dec 20 2019 Martin Jackson <mhjacks@swbell.net> - 0.3.53-1
- First build.

Comment 2 Martin Jackson 2019-12-29 23:48:05 UTC
The upstream situation seems a bit more complicated than I anticipated at first.  (My introduction to this module was by installing it via pipx on a Mac at work; I find it useful and wanted to package it.  At the time of packaging I was unaware of the tests failing on 3.8).

So the 0.3.53 is not the version that pipx installs; the one I've used is actually 0.3.51.

I've opened an upstream issue on the test failures: https://github.com/chimpler/pyhocon/issues/220.  I'll keep an eye on that; but I'm not as sure as I was when I started that this is suitable for distro inclusion.

I have a number of other python utilities I would like to package; is there a protocol for leaving this open for a few weeks while we see what upstream wants?

Comment 3 Robert-André Mauchin 🐧 2020-01-06 17:40:16 UTC
You can keep this open as long as you want.

NEEDINFO me if there is any update from upstream.

Comment 4 Package Review 2021-01-06 00:45:15 UTC
This is an automatic check from review-stats script.

This review request ticket hasn't been updated for some time. We're sorry
it is taking so long. If you're still interested in packaging this software
into Fedora repositories, please respond to this comment clearing the
NEEDINFO flag.

You may want to update the specfile and the src.rpm to the latest version
available and to propose a review swap on Fedora devel mailing list to increase
chances to have your package reviewed. If this is your first package and you
need a sponsor, you may want to post some informal reviews. Read more at
https://fedoraproject.org/wiki/How_to_get_sponsored_into_the_packager_group.

Without any reply, this request will shortly be considered abandoned
and will be closed.
Thank you for your patience.


Note You need to log in before you can comment on or make changes to this bug.