Bug 178679 - fxload not found
fxload not found
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 04:17 EST by Bart Vanbrabant
Modified: 2014-03-16 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-07 17:38:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart Vanbrabant 2006-01-23 04:17:03 EST
Description of problem:
Because hotplug is removed fxload isn't installed anymore. When booting udev
says it can't find /sbin/fxload This is needed for hardware like my external usb
tv-tuner to load the firmware.

Version-Release number of selected component (if applicable):
Latest rawhide where hotplug is removed

How reproducible:
Boot with hardware that need fxload
Comment 1 Bill Nottingham 2006-01-23 10:32:11 EST
Hm, this is probably best handled by a separate package.

Out of curiousity, why doesn't it use the firmware hotplug interface?
Comment 2 Bart Vanbrabant 2006-01-23 10:45:46 EST
I don'tk now. Are there other ways to load firmare? It's a gpl'ed driver from
plextor. 

http://oss.wischip.com

This is the driver: http://oss.wischip.com/wis-go7007-linux-0.9.7.tar.bz2

It installs a file in /etc/udev/rules.d/ with this content:

ACTION=="add", BUS=="usb", ENV{PRODUCT}=="93b/a002/*", \
  RUN+="/sbin/fxload -t fx2 -I /lib/firmware/ezusb/hpi_PX-M402U.hex"
ACTION=="add", BUS=="usb", ENV{PRODUCT}=="93b/a004/*", \
  RUN+="/sbin/fxload -t fx2 -I /lib/firmware/ezusb/hpi_PX-TV402U.hex"
ACTION=="add", BUS=="usb", ENV{PRODUCT}=="eb1/6666/*", \
  RUN+="/sbin/fxload -t fx2 -I /lib/firmware/ezusb/hpi_LR192.hex"
ACTION=="add", BUS=="usb", ENV{PRODUCT}=="eb1/6668/*", \
  RUN+="/sbin/fxload -t fx2 -I /lib/firmware/ezusb/hpi_StarTrek.hex"
Comment 3 Neal Becker 2006-01-23 20:57:21 EST
Funny you should mention, this is exactly the same driver I'm needing. 
 
It won't build on new kernels because of usb changes.  But then this fxload 
issue broke it even more.  Any patches? 
Comment 4 Bart Vanbrabant 2006-04-03 07:42:14 EDT
A new version with 2.6.16 support has been released:
http://oss.wischip.com/wis-go7007-linux-0.9.8.tar.bz2

If you want to compile the driver for rawhide you need this patch:
http://files.zoeloelip.be/wis-go-0.9.8-2.6.17.patch

Are there any docs available on how to load firmare without fxload?
Comment 5 Bill Nottingham 2006-04-03 17:21:47 EDT
Basically, the driver would need to be converted to the kernel sysfs firmware
interface.

In the meantime, I don't think there's really anything preventing fxload being
added to Extras, and possibly back to core later; as it's an out of tree driver,
I'm not sure it's necessary for Core right away.
Comment 6 Bart Vanbrabant 2006-04-12 05:27:06 EDT
I've create a spec file for fxload from the hotplug spec file in FC4. I hope
this can be used to put fxload into extras or in core.
Spec files, srpms and rpms:
http://files.zoeloelip.be/fxload/
Comment 7 Bart Vanbrabant 2006-12-07 17:31:31 EST
Any news? It would be nice if this could be included somewhere.
Comment 8 Bill Nottingham 2006-12-07 17:38:58 EST
I'm sorry. I should have responded sooner. This is best done by going through
the Extras package review process - see
http://fedoraproject.org/wiki/Extras/Contributors

My apologies again for not replying sooner. Closing as WONTFIX for Core, but it
certainly can be added for Extras with a willing maintainer.

Note You need to log in before you can comment on or make changes to this bug.