Bug 178681 - [RFE] Please update sqlite to newer version
[RFE] Please update sqlite to newer version
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 05:35 EST by Dawid Gajownik
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 17:04:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawid Gajownik 2006-01-23 05:35:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051228 SeaMonkey/1.5a

Description of problem:
Would you be willing to update sqlite in FC-4 to newer version (3.2.2 or later)? I've pushed python-sqlite2 to Fedora Extras 4 and noticed that it does not work with older sqlite (yes, I screwed the job up totally - I've been testing python-sqlite2 mostly on my Rawhide box).

Version-Release number of selected component (if applicable):
sqlite-3.1.2-3

How reproducible:
Always

Steps to Reproduce:
1. rpm -q sqlite

Additional info:
Comment 1 Paul Nasrat 2006-01-24 15:30:07 EST
Seems reasonable.

 3.2.8-1 will hit rawhide tomorrow if you have a chance can you rebuild that on
FC-4 and test basic sqlite operation and yum still functions as expected.  If
you don't have time I'll test when I do.
Comment 2 Dawid Gajownik 2006-01-25 06:13:14 EST
Thanks, I'll try to test it on my machine. This packages should be checked
whether they still work correctly:

[y4kk0@X ~]$ repoquery --whatrequires --alldeps sqlite
rpm-devel-0:4.4.1-21.i386
logjam-1:4.5.2-1.fc4.i386
net-snmp-0:5.2.1-12.i386
net-snmp-0:5.2.1.2-fc4.1.i386
krecipes-0:0.9-2.fc4.i386
ethereal-gnome-0:0.10.14-1.FC4.1.i386
apt-0:0.5.15cnc7-6.fc4.i386
krecipes-0:0.9.1-1.fc4.i386
ethereal-0:0.10.14-1.FC4.1.i386
net-snmp-utils-0:5.2.1.2-fc4.1.i386
rpm-libs-0:4.4.1-21.i386
rpm-devel-0:4.4.1-22.i386
rpm-build-0:4.4.1-22.i386
digikam-0:0.8.0-1.fc4.i386
sqlite-devel-0:3.1.2-3.i386
sqlite-0:3.1.2-3.i386
rpm-0:4.4.1-22.i386
ethereal-0:0.10.13-1.FC4.2.i386
net-snmp-utils-0:5.2.1-12.i386
ethereal-0:0.10.11-2.i386
python-sqlite-0:1.1.6-1.i386
python-sqlite2-0:2.1.0-1.fc4.i386
rpm-build-0:4.4.1-21.i386
libopensync-0:0.18-5.fc4.i386
digikam-0:0.8.1-1.fc4.i386
exim-0:4.54-1.fc4.i386
ethereal-gnome-0:0.10.13-1.FC4.2.i386
ethereal-gnome-0:0.10.11-2.i386
logjam-1:4.5.1-5.fc4.i386
apt-0:0.5.15cnc7-2.i386
vdr-muggle-0:0.1.9-1.lvn.1.4.i386
vdr-muggle-0:0.1.9-1.lvn.3.4.i386
rpm-0:4.4.1-21.i386
rpm-libs-0:4.4.1-22.i386
[y4kk0@X ~]$
Comment 3 Dawid Gajownik 2006-01-25 06:41:34 EST
I noticed in spec file that you remove static libraries using `rm' command. It
would be better to pass `--disable-static' option to configure script. This can
speed up build process.
Comment 4 Dawid Gajownik 2006-02-02 11:24:55 EST
I did not spot any problems so far with rpm or yum (sqlite-3.2.8-1). That may
mean that:
1) sqlite does not break backward compatibility
2) I'm a lame tester and my regression tests look like those made by Linus →
http://www.ussg.iu.edu/hypermail/linux/kernel/9804.1/0149.html ;-)

Can you push this package now to updates-testing repo, please? It needs wider
testing.
Now I switched to sqlite-3.3.3-1 and python-sqlite-1.1.6-3 and will check
whether something breaks.
Comment 5 Paul Nasrat 2006-02-02 17:04:07 EST
I'm not planning on updating fc4 right now - newer sqlite will be in FC5.

Note You need to log in before you can comment on or make changes to this bug.